InfiniteMac OSx86

InfiniteMac OSx86 (
-   Snow Leopard 10.6 (
-   -   [GUIDE] Retail Snow Leopard DVD install for G31M-ES2L (

zod1988 08-20-2009 02:46 PM

Great guide!

Sadly as soon as it starts to copy files I get a kernel panic from IOATAFamily and I don't really know why....

This is on a P35-DS3P with a perfectly working install of Leopard

Snow 08-20-2009 02:54 PM

When installing from USB drive?

I had to use -x32 flag because installing from 64bit would panic.

zod1988 08-20-2009 02:58 PM

Yes, booted and installed from USB-Drive in 32Bit Kernel.

I'm a litte clueless, because it recognized all my devices and I even repartitioned the drive from the Installer and everything worked.

sk1nhd33t 08-20-2009 03:03 PM

i only have one hackintosh which is a G31M mobo, havent tried doing this method on any other motherboard so YMMV ;)

@zod1988 & Snow

is the kernel panic the same as my screenshot posted one page 1? if so, maybe it's the uuid, for some reason if the uuid is missing or mismatch it will kernel panic immediately. if it's not then i have no more idea.

@snow glad that it now worked for you and my guide help a bit. chao!

edit: BTW USB installer boots and install fine on 64bit using this board.

zod1988 08-20-2009 03:07 PM

No, it's definately a different one caused I remembered your's :D

Mine specifically mentions IOATAFamily as the cause of the panic....

Snow 08-20-2009 03:21 PM

Odd since I dont need any ATA related kexts installed with my board.

Maybe try to copy your Leopard IOATAFamily kext into extras folder (if you are using a custom one that is) but make sure you use 32bit when installing. It could be drive related but I used an old 5200 rpm ATA drive that makes more noise then a stockcar so cant get any worse then that.

Post back with updates m8, try some stuff but write every step down so you can trace back.

zod1988 08-20-2009 03:22 PM

Well, the harddisk is brandnew so it would be strange if it was that, but I'm gonna try the kext from Leopard as soon as I get home from work ^^

Will report back soon :P

zod1988 08-20-2009 04:11 PM

I tried it with IOATAFamily from Leopard, made all my IDE Drives (Target drive is SATA though) show up, but then crashes because of kextcache, as you can see in the attachment.

Could it have something to do with the fact that the Extension in Extra don't have an Extensions.mkext?


Now I am completetly confused. Tried it several times now, and everytime the cause for the kernel panic is a different one....I had kextcache, Mac OS X Installer and kernel_task cause kernel panics at the exact same step and once just after booting into the installer and letting the computer sit idle for like 10 seconds.

64Bit kernel panics way before even reaching the GUI....

BTW: I made sure all the UUIDS are correct, it panics anyway.

zod1988 08-21-2009 10:35 AM

I also tried to create a kextcache myself, but the kernel panic always happens as soon as it tries to copy files to the target disk (and sometimes even before that...)

saintjoe 08-21-2009 04:46 PM

This guide gave me a perfectly stable 10A432 install on my hackintosh, thanks!


Asus P5Q Pro
C2Q Q6600
KFA Geforce GTX260

64bit-mode doing absolutely fine, panics when entering sleep mode though, but that didn't really work with 10.5 too.

Now only some minor glitches until I dare to use 10.6 as my everyday-system.