InfiniteMac OSx86

InfiniteMac OSx86 (
-   Snow Leopard 10.6 (
-   -   [GUIDE] Retail Snow Leopard DVD install for G31M-ES2L (

blancmaison 11-07-2009 04:42 PM

boot from usb hdd not pen drive
Can you do this from a usb hdd not a pen drive ? currently I have one usb hdd but not a pen drive, when I do boot rom it all i get is the blinking cursor at the top of the screen ? any help ?

Jocelyn84 11-07-2009 10:21 PM

Yes! An external hdd works, as it's how I did my install on a rev 2 board. I even had a drive with 2 partitions, added a third 10gb partition, and put snow install on it. I'm not sure if it matters, but is your drive guid partition mapped?

infiniteThanks 11-08-2009 02:59 AM

Everything working, now trying to add Ubuntu 9.10
I followed the guide and my system has been up and running for many days now. Many thanks to people on this forum. I even upgraded the system from a lowly E5200 to a Q9550. I guess I want to do more.

(a) Add a clean Ubuntu
I installed Ubuntu and then reinstalled Chameleon. Chameleon recognizes the Linux partition. When I select the linux partition and boot, grub complains about unknown file system and then throws me into grub rescue.

This is the latest and greatest Ubuntu 9.10. Ubuntu boots after installation but does not boot after Chameleon is installed even when Chameleon can see the Linux partition.

Ubuntu is now using ext4 as default file system.

(b) Restore Ubuntu from another machine instead of installing a clean copy. I have not go this far yet. I guess I will use dd (with care).

So yeah, I am asking for trouble and probably deserve it but any advice from someone who has done a clean install or better yet, a restore from another Ubuntu install under Chameleon, will be appreciated.

infiniteThanks 11-08-2009 07:15 AM

Got Ubuntu 9.10 and ES2L hackintosh running fine now !!!
I could not get Chameleon to launch OSX so I decided to use grub to launch OSX. Ubuntu 9.10 has moved to Grub 2, different from legacy grub. Ubuntu will detect OSX HFS+ boot partitions and create boot menu items and scripts but I it kept on getting kernel panics when I used the grub boot menu ... something to do with invalid number of arguments somewhere in the stack.

Also, unlike legacy grub, grub 2 can read HFS+ partitions.

In Ubuntu, use Gparted to find out which partition has your OSX installed.

Then add a very simple menuitem in Ubuntu grub configuration file:
/boot/grub/grub.cfg (note: used to be /boot/grub/menu.lst in legacy grub)
Use any editor. Make sure you have to have admin privileges to save the changes.

menuitem "Mac OSX boot or whatever you want to call it" {
insmod hfsplus # loads hfs+ module. Grub 2 can read hfs+ files !
set root=(hd0,6) # your partition may be different
multiboot /boot # used to be called kernel in legacy grub.
boot # not really necessary; it is implied

Now reboot. You will see your new entry in the grub boot list. Use arrows to select it. It will now boot into chameleon.

I think someone can make it better.

blancmaison 11-08-2009 08:33 AM


Yes it is guid , I am waiting for the board that is mentioned in the post to turn up so I thought I would try to build the boot disk on my old emac onto a usb hdd I have , I have tried different format options as well , I then tried the usb hdd on a dell optiplex gx 520 which normally like hackintosh but just get a blinking cursor.

latinoguy 11-08-2009 04:10 PM

Excelent guide i used in my GMG31-S2C I HAVE SL WORKING BUT...
Thanks for the guide, is excellent, but i mixed up with the DSDT patch and my motherboard is different that in the guide the chipset is the same, i have problems with video when i write the string line with efi studio the resolution that i only get is 1024x768, and the sound not working at al the kext that i use is the ACL662 but no exit, so i had to use and external audio, I need help to get this working at fully capacity, by the way, im using a 7600gt nvidia 256 mb and a cpu intel dual core 5200, but im going to buy an E7500 core two duo and start over again, any sugestions or advices? thanks

infiniteThanks 11-08-2009 09:31 PM

E5200 is plenty enough.
Hi latinoguy,
Some thoughts:
E5200 is good enough. I built a full system on the ES2l with no issues. I moved to a Q9550 because I was doing heavy image processing.

DSDT : One problem could be that your DSDT may be very different. DSDT is, in very crude terms, a representation of the hardware configuration by the BIOS to the software. Hence, just having the same chipset does not help all the time.

If you find a good DSDT for your motherboard/BIOS version out somewhere, use it. Getting the DSDT from the OSX system is not good enough; it just returns the one you just put in. A good way to get a DSDT is to download a Linux live ISO (Knoppix, Ubuntu, etc.), burn it to a CD and boot from it. Create a terminal window, and type:

sudo cat /proc/acpi/dsdt > DSDT.aml

Then you use DSDTSE app in the ES2L Kit to patch it, compile it, and save it to either the / and/or the /Extra folder(s).
There are fixes that you have to make; see OP.

Rebuild the /Extra/Extensions.mkext with the MKextTool, Kext Utility, or the command line. See posting by me and followups to it.

Make sure the permissions are correct: use the Disk Utility to fix it, not the script.

Clean all caches and retry :)

latinoguy 11-08-2009 10:40 PM

Hi, thanks for the quick response, now i have internet and video working at full capacity, just the audio, but with the usb audio no problems i can live with that, now i have to work in the rosseta so i can play chess in with the java application and as i understand, i dont need another cpu? do i have a good one? thanks.

latinoguy 11-08-2009 10:52 PM

I did the repair permissions thing that you recommend to me and this is what i get is a screen image of my pc, thanks for your advice.

antonehenry 11-09-2009 01:14 AM

I can't boot from usb thumb drive, or a western digital mybook external hard drive.

This is starting to drive me crazy. Neither will boot. It just goes straight into Windows 7 on my other partition. I tried to put both as first boot device in bios, and then tried to do it from the boot menu. No dice.

I have a g31m-es2l I bought yesterday, core 2 duo e8200, 2gb ddr2 800 ram... I don't know what the problem is. It just won't boot from the external drives.

Any help? I am so lost at this point.