InfiniteMac OSx86

InfiniteMac OSx86 (
-   Snow Leopard 10.6 (
-   -   [GUIDE] Retail Snow Leopard DVD install for G31M-ES2L (

sk1nhd33t 08-17-2009 09:24 AM

[GUIDE] Retail Snow Leopard DVD install for G31M-ES2L

March 12, 2010: sold my ES2L Quicksilver PowerHack a few weeks back so my last update on this guide... it's been fun guys since we started this thread (August 17, 2009 - it all starts on Leopard thread here).. i'm sure we will bump on each other again on this forum and the others out there and i'm positively sure that the gurus here will keep this thread updated with new fixes, patch etc when 10.6.3 comes out (and also me if i can)..

- now for the updated ES2L kit, all current DSDT fixes including the ff:

- Vanilla speedstep (edit the PSS code for your processor - go here for more info)
- shutdown (thanks to mm67)
- restart (use asere bootloader included in the kit but thanks to duvel for introducing this fix)
- USB fix
- Apple Aluminum Keyboard Wakeup Fix (again thanks to mm67)

11/15: updated the ES2L kit to include latest software from conti, bonjour kext and other dsdt fixes.
11/9: Apple Releases Mac OS X 10.6.2, to update remove sleepenabler first then use the combo or software update. You can get the new sleepenabler kext at netkas site
10/9: guide updated again to base an RC3 + PC_EFI 10.3 and include all updated kext using Conti's myhack installer. Older RC1+PCEFI 10.1 guide dated 9/3/09 can be found here.
9/20: Netkas released PC EFI v10.3, if you are using the old 10.1 or RC3 may i suggest that you use this instead. Here's a screenshot of my boot.plist before and after 10.3 and PCI System Profiler.
9/20: Finally a fix that im really happy about, automatic sleep can now be achieve by using PleaseSleep application. a much better alternative is by KWS. keep a disc inside your dvd drive to make Auto Sleep work
9/10: 10.6.1 is out, no kernel change has been made so update away!
9/4: No more need for RealtekR1000.kext to have bonjour working, use this kext instead. (works in 32bit only) use SnowR1000 included in the kit
9/3: revise the guide from scratch to base a retail DVD install (comments starts on page6), for the old dual OS 10A432 boot guide dated August 17 click here.

im quoting this from Stella's Blog: "Friends don’t let friends install OS X via OSInstall.mpkg. This guarantees a buggy installation, bad system permissions and possible kernel panics. If you’re going to install your OS either use the retail DVD or restore it to a high capacity flash key (8GB minimum). " i'll also add that using a flash drive or DVD will remove the "no installer package error" in Disk Utility, there is a workaround by running bsd.pkg from within Snow Leo but i havent tested it myself and a few can attest that it didn't work on them. For more OSX86 news I suggest subscribing to stella's blog via RSS or bookmark, lots of good info there which get updated constantly.

What's Needed:

- first download new ES2L Kit and place it in your Desktop. old kit can be downloaded here
- Retail Snow Leopard $29 DVD Disc
- Gigabyte G31M-ES2L Motherboard Rev 1.X F8/F10 Bios is used in this guide
- Intel Core 2 Duo or Quad Processor
- a separate Graphic Card-built in Intel GMA 3100 will not work
- 8GB flash drive
- Sata Hard Drive in any capacity (for this guide we use a dedicated HD)
- OS X machine, could be another mac, hack or another partition if you have

Create Snow USB installer:

● launch Disk Utility then choose your USB drive, under Volume Scheme select 1 partition and erase your USB drive to GPT (Guid Partition Table)
● click the restore Tab and select Mac OSX Install DVD as the image and your USB flash drive as the destination, also be sure that 'Erase' Destination' is unchecked before clicking restore.

● open your ES2L Kit and under tools double click myHack installer choosing your USB flash drive as the destination.

● under Customize put a check on the following:

- GraphicsEnabler - depending on your graphics card this option will auto enable most ATI and nvidia cards. (my Palit 9600GT works OOTB), if it doesn't work on you, try pci0 or the older method which is EFI strings.
- LegacyAppleRTC (optional since we will be fixing CMOS reset bug before we even shutdown/restart)
- fakesmcV2
- NullCPUPowermanagement
- OpenHaltRestart
- PlatformUUID (optional)

● under Themes, copy/paste "bootcamp" folder to Extra/Themes of your USB drive, you can skip this if you are happy with the default myHack theme.
● add the following entry (mark in red box) to your, while your at it you can also add your monitor's resolution. Don't forget to save when done.

● we now have a bootable USB Snow Leopard installer, copy ES2L Kit to your USB drive because we will be using it later. when done you can now shutdown your OSX machine.

Boot and install Snow Leopard via USB:

● Turn on your computer and press Boot Menu F12, when you see the selection screen choose your USB flash drive as the first boot and press enter.
● Chameleon screen will pop up next - choose your USB drive again and press enter or you can boot in verbose mode by entering "-v" (without the quotes) or via drop down menu. In a few seconds If all goes well you will be greeted with Snow Leopard language screen
● Launch Disk Utility then choose the hard drive you will be installing Snow Leopard
● format your SATA drive using GPT and Mac OS Extended (Journaled), quit disk utility when done. You can also customize the install if you want to removing printer drivers, language etc... im sure you know what to do here so just proceed until installation is finish.
● after the installer is done, click restart

First Boot:

● press F12 Boot Menu again then choose your USB flash drive, we need to do this because our SATA drive is not bootable on it's own yet
● on the Chameleon selection screen, choose your never booted Snow Leopard drive/partition
● again you can either just press enter on your keyboard or boot it in verbose mode (typing "-v") to see what's going on.
● if all goes well you will greeted with Snow Leopard intro video but no sound yet - depending on your graphic card you will notice that QE/CI is already activated... continue the setup process until you reach your desktop
● yey! we now have a fully functional 32bit Snow Leopard. but wait - we have no sound and it's not bootable on it's own.

DSDT, Audio and remaining fixes:

● open your ES2L kit and under tools run myHack installer again but this time choosing your Snow Leopard drive/partition as the destination
● under Customize put a check on the ff:

- GraphicsEnabler
- fakesmcV2 (you can replace it after with a newer 2.5 version by Netkas)
- NullCPUPowermanagement
- OpenHaltRestart
- PlatformUUID
- SleepEnabler

● open Kext folder and look for "LegacyALC883.kext" and copy it to /Extra/Extensions
● open smbios-plist folder and copy "smbios.plist" to /Extra -included are iMac 9,1 and MacPro 3,1. Also edit it to match your hardware
● Under Themes copy bootcamp theme - again this is optional if you are happy with the MyHack default theme
● edit adding the following in red box:

DSDT quick guide:

● create your own dsdt.aml by following this short guide below, AGAIN it's always recommended to create and use your own.. included my dsdt.aml and .dsl for comparison purposes only.

TIP: If you are using Textwrangler (free) or BBedit, you can compare the difference between the 2 dsdt.dsl by selecting both file, right click and choose "Compare Selected Documents", you can even copy the code difference by clicking an arrow button.

- let's begin... be sure you have a good texteditor handy (eg Textwrangler, BBEdit etc..)
- open ES2L kit Tools then "DSDT_Patcher1.0.1e" folder and double click "DSDT Patcher"
- a terminal window will open then press any key to continue
- next it will ask "Which OS to emulate? [0=Darwin, 1=WinXP, 2=WinVista]" input "0" and press enter
- a new Debug folder will appear and inside it are a few files but we are interested in "dsdt.dsl"
- open your dsdt.dsl using your preffered texteditor so we can start editing
- also as reference, open my included dsl to copy from it directly or check how it's done
- on your keyboard press "command F (Find)" and look for "_WAK", right above it copy paste "DTGP" located on your dsdtfix file
- again "command F (Find)" and enter RTC, look for "0x04" below RTC and changed them to "0x02" - this fix is for CMOS Reset
- command F (Find) and enter Azalia, go to dsdtfix file and copy paste "HDEF" to your dsl replacing azalia.. again check my included dsl for reference - this is for ALC883 Audio
- when done and sure everything is correct, hit save or (command S) to save your dsdt.dsl
- to compile it to .aml, drag and drop it (dsdt.dsl) to iAslMe, you'll get 1 warning (PARM under IGD0) but hopefully you have 0 error
- look for Sessions folder and copy dsdt.aml to /Extra of your Snow Leopard

● double click "pfix" (permission fix) then choose your snow leopard drive (type "/"), it will take a few minutes to create a new extension.mkext and repair permission but just be patient. reboot when done.
● after reboot for the Audio to take effect, launch System Preference then go to Sound and choose Internal Speakers/Built-In Speaker for both Sound Effects and Output Tab, press F11/F12 (apple keyboard), F14/F15 (for windows?) to test if you can hear a feedback.


1: RTGMac_v2.0.3 - this works in 32bit only, open Bonjour Fix on your ES2L kit and run the included pkg, reboot and done.
2: via ifconfig PROMISC from here (32 and 64bit)

- to make PROMISC work there are 2 ways, one is via applescript which you can add on your startup and the other is via LoginHook, both of them work so use the method you prefer

- Use R1000 installer that's included in the ES2L Kit- Credits goes to Bit Shoveler & weeksauce12


● you can edit located in /Extra and remove "arch-i386" after Kernel Flags if you wish to boot in 64bit, this can be done using a Texteditor (e.g. TextEdit, Textwrangler, BBEdit etc) or Terminal (nano).


Conti for myHack installer and PFix script
Pista7 and cparm for sleepenabler
Netkas for PC EFI and fakesmcV2
coconup for HDEF dsdt patch
ApexDe for USB wake-up FIX
Voyn1x for LegacyALC883.kext
Bit Shoveler & weeksauce12 for R1000 bonjour kext

☑ i'm also new when it comes to OSx86 scene and this is my first and only hackint0sh, just sharing what i have experience and worked for me. So if anyone has a kext, patch or any improvement in terms of install, boot or any changes that needs to be done please do post them here or PM it to me. i'm sure lots of members including me will benefit from it.

- if in case you miss it on top, new ES2L Kit can be downloaded from here.

DocShadow 08-17-2009 01:29 PM


Originally Posted by sk1nhd33t (Post 31269)
- why use a flash drive? because installing it inside Leopard will make a no installer package error in Disk Utility hence you cant use it, it will also work on another partition but didnt try it since i have a few spare flashdisk unused.

Thanks for the detailed write up. The more success we have the more options for people to try.

I restored the Install DVD to a partition on the same drive on which I installed SL and can confirm that it also works and you don't get the "no installer package" error in Disk Utililty.

arsonwells 08-17-2009 05:53 PM

Very nicely done and much appreciated.

For some reason I keep getting kernel panics during the installation, but I restored the burned version of Snow to the SD instead of the original DMG. Gonna try it the right way now. Will update results.

mitchde 08-17-2009 10:40 PM

Whats this with that UUIDs of the USB boot drive.
Once it had for booting to install SL on an other partition.
Then boot again from usb to boot the installed SL from HD.
But before that booting delete the uuid (of usb).
Whats happen if the uuid on the USB stays ( not deleted) at the first booting from USB > F8 > select SL HD ?

sk1nhd33t 08-18-2009 03:35 AM


Originally Posted by mitchde (Post 31320)
Whats this with that UUIDs of the USB boot drive.
Once it had for booting to install SL on an other partition.
Then boot again from usb to boot the installed SL from HD.
But before that booting delete the uuid (of usb).
Whats happen if the uuid on the USB stays ( not deleted) at the first booting from USB > F8 > select SL HD ?

i didnt quite understand what you mean but ill try my best to answer it :)

- for some reason the USB installer will kernel panic a few seconds after installing if the UUID is not present, it will boot fine except when you press install on your drive same as arsonwells above.

- on first boot if uuid is present of the USB drive (i deleted it in leopard before booting), snow leopard will stall, it will not continue to boot since chameleon booted the usb's uuid.

- basically i didnt need to install another chameleon to my 2nd partition since i already have a running leopard (hidden EFI) on first so i just copy the Extra folder and add uuid's so chameleon can load the specific extensions folder, but if you plan on installing snow on a seperate drive and plan to make it as a primary boot you can skip the uuid's and just install chameleon/EFI totally disregarding leopard.

edit: this is the kernel panic im talking about, this happens a few seconds after snow is installing. To avoid it be sure boot-uuid is present on the usb's boot.plist and platformuuid's info.plist :)

mitchde 08-18-2009 08:42 AM

Thanks !
Really good step by step guide !!!
I ask about UUID because i have already an working SL A421 on an HD partition.
Has HIS own UUID in boot.plist.
Now i want to boot from it (like USB guide) to install A432 from that OSXInstall.mprg (modded for MBR).
For my understanding:
I leave that UUID (A432 UUID HD) for booting to install A432 on an clean HD partition on other HD.
But what then:
You second boot also to USB but select A432 installed partition to boot further.
Must i delete that UUID on my A421 for that second boot (in bootloader, not A421) into A432 ? You tell that.

I mean that last boot from USB into new A432:
Lets Make it Bootable: now this is very important because on first boot chameleon will automatically choose 64bit as default, and in my experience it kernel panicked immediately so we need to boot it first to 32bit, yours may vary so try 64bit immediately if you want.

- lets leave the never booted snow partition for a while
- make sure that your Leopard partition is on Chameleon RC1 + 10.1 coz this will be our main bootloader, if so boot Leopard partition again.
- go to 8GBsnow extra's boot.plist and delete the boot-uuid entry leaving the Kernel Flags empty


cili0 08-18-2009 10:18 AM

Hi sk1nhd33t,

first of all thanks for your guide, everything works fine here with ga-p35-ds4.
The only problem is the "no package" error in Disk Utility.

I specified the SL partition UUID everywhere

n /Extra/


        <key>Kernel Flags</key>

in /Extra/smbios.plist:



in /System/Library/Extensions/PlatformUUID.kext/Contents/Info.plist:



but it won't work! anyone know where i'm wrong ?

Thanks in advance,

sk1nhd33t 08-18-2009 10:58 AM

@ mitchde

since you have a working snow i suggest you just install 10A432 within that, just created a new partition.. the no installer package error is only present if you install snow within leopard so im sure you are safe.

read more here

@ cilio

did you use my USB guide in installing 10a432 snow? AFAIK the no installer package error is only present if you install it within leopard, please check link above. it's working properly here on my end including the new install i made a few hours ago.

cili0 08-18-2009 11:06 AM


Originally Posted by sk1nhd33t (Post 31361)
@ mitchde
@ cilio
did you use my USB guide in installing 10a432 snow? AFAIK the no installer package error is only present if you install it within leopard, please check link above. it's working properly here on my end including the new install i made a few hours ago.

i've used your guide since the "First Boot" section. But i've installed SL from Leopard.
I'm gonna try to make a SL USB Installer and Repair Permissions from there.


Snow 08-18-2009 11:18 AM

Check the other (specific related) thread m8 and try my suggestion.

I still get KP in 64bit but x32 seems fine. What kexts did you use? (since I have GA-P35-DS3P)

Do not reinstall the BSD package though since it did nothing and messed my system up aferwards (but got it fixed again with above suggestion)