InfiniteMac OSx86

InfiniteMac OSx86 (
-   10.X (
-   -   Asus K50IN (

flip360 10-12-2009 11:45 PM

Asus K50IN
GUIDE for the ASUS K Series / OS X 10.6.x / 10.7.x

The ASUS K50/70 notebook is designed to provide a no-frills computing experience to users while on the move. The K Series of notebooks sport the nVidia MCP79 / MCP75 chipsets containing C2D or CD CPU`s along with nVidia GPU`s which makes them a perfect combo for a macbookpro replacement :P After some testing and tweaking, we (the users of this thread) would like to report that the K series of notebooks are quite compatible running vanilla OS X.

WARNING: We DO NOT take ANY responsibility in case of hardware failure or error.

Section A: Install / Post Install method for 10.6.x
Section B: Install method for 10.7.x* *OPTIONAL


Section A1: OS X 10.6.x Install method

Create a OS X USB Installer:

[ PRE-INSTALL AUTOMATOR v1.1 ] USB Install Method for OS X 10.6.x [from OS X]
[ Installing Snow Leopard via USB ] USB Install Method for OS X 10.6.x [from Windows]

or use Bughalters K50IN BootCD:

[ ASUS K50IN Boot CD ] Installing Mac OS X 10.6 Retail

[ HOWTO Dual Boot ] Install Mac OS X (create 2 partitions, one OS Journaled and the other one FAT, the partition for Windows (later to be reformated to NTFS using Windows installer), remember not to add/remove any partitions using Windows installer - otherwise your partition table may get damaged! When finished install Chameleon using boot0hfs method and that's it, fully working dual boot setup.


Section A2: Post Install Method (HUGE thanks to man_of_the_oak, check out the DETAILED 5 part tutorial below)


Section B: Install method for 10.8.x *NEW


You can use any of the both methods described in the links:

Archive with modified DSDT and AppleSmartBatteryManager.kext for 10.8.x


Thanks to all involved in bringing OS X to the community, happy hackintoshing! :)

Imkantus 10-17-2009 10:57 PM


Originally Posted by flip360 (Post 37306)
(thanks man) on a GUID partition (the other one is a Windows 7).

So Windows 7 supports beeing installed to GUID schema? (Sorry I just wonder about this, but might be so - I am not that much into using Windows. ;))


Originally Posted by flip360 (Post 37306)
1. the audio which is working through VoodooHDA but the Bass sounds are useless and there is also a lot of noise, and

I just found this, when reading through the recent topics... - Hope it helps you. :)

flip360 10-17-2009 11:35 PM

Hello Imkantus,

As i found out myself too, Windows 7 supports beeing installed to GUID ( i have the 64bit version) :))
I have tried that link that you sent but to no avail, i have built in audio in device profiler but i have grey sound icon on the taskbar and no audio :( The voodooHDA kext i have now recognizes the sound as ALC662 Nvidia MCP79 but still noise and scratches. It seems the kext from the link doesnt have the same outputs mapped as i have :( I have a friend that has the same laptop and he sent me working 10.5 kext that i have no knowledge of translating them to snow leo or 64 bit for that matter. I have searched my dsdt for entering the Hdef Patch but i have no AZAL device or anything simmilar, so...F1 :)


thorazine74 10-18-2009 04:05 PM

You would need to get a codec dump from your audio hardware to fix the outputs mapped to the wrong ports. Also you could try using this modded version of VoodooHDA by Slice that lets you remap the ports too, it could be easier than patching AppleHDA from scratch.
Also I'm curious too, I was assuming Windows 7 didnt support installing to a GPT partition even in 64 bits variants, what method did you use?

flip360 10-19-2009 12:01 PM

thanks man will try that kext out and try to map my ports also :) Anyway i first formatted my drive with a GUID partition table, two partitions actually on single HDD, one is hfs the other one was FAT32 from within Disk Utility, installed OSX and than Win7 64bit recognized the fat32 partition. I was amazed too when i saw that it works :))


shawn0694 10-25-2009 05:54 AM

Asus K50IN
I have the same model and components as you and I have been able to get IPC 10.5.6 working but no luck on the graphics card and when I install SL it errors half way through the install and then will not reboot with out kernel panic. any help will be appreciated thanks

flip360 10-25-2009 09:03 PM

first off use this and generate an usb install and then just follow the marks within the script. Afterwards you will need the kexts that i wrote in the first post about and copy them to E/E on the Snow Leo Partition. If you cannot find them let me know and i will upload them somewhere. I used the golden master image of Snow Leo and the script and it turned out to be ok after days of trial and error :) But it works very well as i have tried every other distro available out there, vanilla works best :)

flip360 11-10-2009 05:17 PM

UPDATE: Atheros WiFi is recognized with the new kext from 10.6.2, you just have to add device id :) i just cant seem to connect to any networks and although is shown in system preferences and profile ifconfig gives me this:

ether 00:24:23:0a:05:fe
media: autoselect (<unknown type>) status: inactive
supported media: autoselect

and profile gives me this:

Card Type: AirPort Extreme (0x168C, 0x1089)
Firmware Version: Atheros 9285:
Locale: Unknown
Country Code:
Supported PHY Modes: 802.11 b/g/n
Supported Channels: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14
Wake On Wireless: Supported
Status: Not Associated

if anyone knows any solution please help :)

flip360 11-12-2009 07:30 PM

UPDATE: I gave up and installed the Dell 1490 miniPCI (which is very easy to do on my laptop) and BAM working airport OOTB :)) Thanks imkantus for the choice :) The atheros card was recognized but it did not scan for networks or finding any for that matter, so it had to go.


RGGG 11-13-2009 03:09 PM

1 Attachment(s)

I just picked up this laptop myself. I've swapped out the wifi, and am planning on loading up snow leopard this weekend. Could you be kind enough to posts the kext's that you used for your installation.

Also have you tried this kext for your realtek card? I've read around and it seems to be working pretty well. Replace your dsdt.dsl in /Extra with the one in the zip file and put the ALC662.kext in /Extra/Extensions. Rebuild the Extensions.mkext in /Extra (if your using Chameleon 2).