InfiniteMac OSx86

InfiniteMac OSx86 (
-   Leopard 10.5 (
-   -   Possible solutions for "Still waiting for root device" (

mkarotis 03-15-2011 07:25 AM

still waiting for boot
I have in my pc a sata hdd a sata dvd and a IDE hdd. I installed leopard 10.5.2 (kalyway) on my sata hdd and worked just fine. I could see all the other drives. When I tried to install snow leopard 10.6.3 (iatkos) on my sata hdd after installation I could not boot "still waiting for boot device". I have installed snow leopard on IDE hdd. It boots ok but I cannot see my dvd drive. I have an ASUS p5k mb (jmicro) I have ACHI in my bios.
What I do wrong? Why 10.5 works on SATA and 10.6 not?
I would be ok if at least I could intstall 10.6 to IDE hdd and I could see my dvd drive in snow leopard

BioShawk 04-21-2011 07:54 PM

Hello iam really new to mac iv been trying to install iDeneb 1.5 i think with my

AMD Phenom II X3 710 2.6Ghz (iv turned on the fourth core so now its)
AMD Phenom II X4 10 2.6Ghz
Sappire ATI HD4870 Vapor-X
i have one hard disk which is ATA or sata iam not sure its called
and my burner is allso sata cabeld
iv turned the partition active made AHCI and all the settup needed but i still get Still waiting for root device and i cant get to boot screen
i have only one hard drive of 500G iv made a partition which isnt formatted to any kind of file setup and i made it active now
at the boot up i put rd=disk0s3 and any kind of setting iv tried still led to "Still Waiting For Root Device"
-f -v
-v -f -x
-f -v -x rd=disk0s3 and stuff now i have 3 partitions
disk0s1 system resereved
disk0s2 windows 7 files and stuff
disk0s3 unformatted active for Mac OSX
now iam allso runing with a wireless logitech set EX100 and a razer mouse Imperator i think that might do with the probleme iv puted the
hard drive setting which is sata to AHCI and the other one the 4/5 to IDE iam getting this probleme for a month now and i cant install it

etuzumaki 05-18-2011 12:42 PM

So Depressed
Hi, i am newbie here, i like to install mac os x tiger jas 0s to my laptop, but it only come with "still waiting for root device" message..i have tried typing many codes but it seem useless.....i am so depressed now, anyone can help me please? i use Toshiba Satellite L300, please help me....

Hozey 05-24-2011 01:14 AM

s3 Still waiting
The installation of iATKOS S3 v2 seemed to go smoothly on Fijitsu B Series Lifebook with Pentium M 1.2GHz processor and 1GB of memory. Booting is beyond me. I've tried everything I can find on this site and many others as well as other distros to get past the following:

From path: "uuuid",
Waiting for boot volume with UUID D7A3D273-CEDB-CDB1-A2CF-0A50CBACDCAD
Waiting on <dict ID="0"><key>IOProverClass</key><string ID="1">IOResources</string><key>IOResourceMatch</key>string ID="2">boot-uuid-media</string></dict>
netkas presents fakesmc, a kext which emulates smc device load successed
Still waiting for root device

Any and all help will be appreciated. This is my second Hack. I was hoping it would go as well as the first.

johnbravos 11-18-2011 08:35 PM

i have a foxconn h55mxv and i have this problem"Still waiting for root device".i should buy another motherboard or i can try some patches?