InfiniteMac OSx86

InfiniteMac OSx86 (http://infinitemac.com/forum.php)
-   Lion 10.7 (http://infinitemac.com/forumdisplay.php?f=100)
-   -   Lion with AMD (http://infinitemac.com/showthread.php?t=7106)

Seby 07-25-2011 06:15 PM

Anyone is working on it?

maya77 07-25-2011 09:40 PM

History repeats...

Voodoo Team have done great work on 10.5 kernel for AMD.
10.6 came out, Voodoo Project was dead, and we were not able to run 10.6 on AMD for a long time (at least there was no stable solution).

nawcom made great legacy kernel for 10.6/AMD users. We were happy and satisfied again.
10.7 is out, unfortunately nawcom has some serious medical issues, and we have to wait for some new legacy kernel project.

davisin666 07-25-2011 10:34 PM

Quote:

Originally Posted by maya77 (Post 54629)
History repeats...

Voodoo Team have done great work on 10.5 kernel for AMD.
10.6 came out, Voodoo Project was dead, and we were not able to run 10.6 on AMD for a long time (at least there was no stable solution).

nawcom made great legacy kernel for 10.6/AMD users. We were happy and satisfied again.
10.7 is out, unfortunately nawcom has some serious medical issues, and we have to wait for some new legacy kernel project.

And AnV???

wastez 07-26-2011 08:38 AM

What i know is one of the problems that the kernel source is incomplite.

Im not really sure but i think anv also takes the diff from nawcom. (correct me if im wrong)

Looks like it will take a while till we get a legacy_kernel which works.

Unrealized 07-31-2011 07:42 PM

Any news yet? I bought Lion already. :)

I would have tried compiling a kernel with the legacy kernel diff but it would have needed a Lion installation first in order to compile. :-/

Does Lion require full 64-bit mode? (Which isn't possible for me with Legacy Kernel on SL at least)

Hadriel 08-09-2011 09:22 AM

so with a patched kernel, would it be possible to run lion on my PC?
I really want to get a Tri-boot going.
AMD Phenom II X6 1100T
16.0 GB Dual-Channel DDR3
Gigabyte Technology Co., Ltd. GA-870A-USB3
AMD Radeon HD 6970 2GB

(Any other info on my PC: http://speccy.piriform.com/results/4...wlfmhtwdAsCIrJ)

Seby 08-09-2011 11:35 AM

That's the problem.. we need patched kernel first

Unrealized 08-09-2011 05:56 PM

Quote:

Originally Posted by Seby (Post 54842)
That's the problem.. we need patched kernel first

Yep, now if we only had someone to do the job for us.. Or someone willing to buy me a macbook pro so I could compile the Lion kernel with legacy kernel diff ;)

Lordadmiral Drake 08-11-2011 05:25 PM

@unrealized: Can't you compile on your hack under 10.6.7?

Unrealized 08-11-2011 07:01 PM

Quote:

Originally Posted by Lordadmiral Drake (Post 54877)
@unrealized: Can't you compile on your hack under 10.6.7?

It needs the newest Xcode, which needs Lion. :(