InfiniteMac OSx86

InfiniteMac OSx86 (http://infinitemac.com/forum.php)
-   Lion 10.7 (http://infinitemac.com/forumdisplay.php?f=100)
-   -   10.7.4 AMD Kernel (http://infinitemac.com/showthread.php?t=7687)

R:A:W:X86 05-19-2012 07:40 AM

10.7.4 AMD Kernel
 
1 Attachment(s)
This is my assembly of 11.4.0 XNU / Lion Kernel patches. :cool:

I started this with the aim to achieve the most optimal function on my AMD FX equipt workstation, even though it also works on many other AMD & legacy-Intel machines with some limitation, as it is based on the patches made for previous versions of the XNU Kernel.
http://img6.imagebanana.com/img/2wrt6h3q/Linie.png
Release Notes:

  • Owners of non-SSSE3 capable CPUs are currenlty limited to the Legacy mode (i386 Kernel without 64-Bit support enabled). If this concerns you, you have to use -legacy boot flag & Finder.app from DP2. The creation of an emulator could solve this in future time.
  • Some people (including Bulldozer users) may need to advice the correct clock multiplier to the Kernel as auto-detection fails. Examples: busratio=13 (multiplier 13) or busratio=105 (multiplier 10.5)
http://img6.imagebanana.com/img/2wrt6h3q/Linie.png
Download:
last update: 2012-07-18



Download XNU Kernel only:

CLICK HERE TO DOWNLOAD LATEST KERNEL

Mirror: ifolder.ru / 4shared (by starwa314)




Download XNU including source code & past test series: xup.in / ifolder.ru

Would be great if someone would contribute to this.
In case you gonna do, please consider to keep the source code avaible to the public.
This release is the effort of many people, without open source it would not be.
How-To fix 32-Bit Apps in 64-Bit mode

As the Kernel features some patch made by AnV that automaticaly turns code signature to valid, I was able to fix 32-Bit Apps to work on 64-Bit enabled AMD machines (Bulldozer).

This requires sysenter traps to be patched in /usr/lib/dyld and /usr/lib/system/libsystem_kernel.dylib

There is a Lion compatible Version of amd_insn_patcher by AnV that works for Lion. Old versions will not work as the sysenter trap has changed in Lion.
Get it from here:
http://osx86.co/f36/legacy-kernel-10...post55947.html

Usage: amd_insn_patcher unpatched_file patched_file

Be sure to fix file permissions before you copy over & use "sudo update_dyld_shared_cache" afterwards.

http://osx86.co/attachment.php?attac...1&d=1338725292

So far all my Apps 32- & 64-Bit are working without issues. :cool:
http://img6.imagebanana.com/img/2wrt6h3q/Linie.png

credit & respect to:

bronzovka, mercurysquad, semthex, quoopz, Kabyl, AnV, kaitek, ovof / paulicat, apocolipse & anyone who may have been forgotten to be mentioned here



phuc25kt 05-19-2012 08:32 AM

Can you give me link to download ! please!

R:A:W:X86 05-19-2012 08:41 AM

Download is avaible from ifolder.ru or xup.in

m28ew 05-19-2012 01:58 PM

@R:A:W:X86

Thanks for the legacy kernel 11.4.0 (Y)

Confirmed! It also works on my AMD + system.kext 10.7.4 (no boot-errors found)

http://s13.postimage.org/5r1zf8k9z/kernel1074amd.png

jackokk 05-19-2012 02:38 PM

awesome!!!

Your kernel can work nearly perfect on my AMD Athlon II X4 620 (Lion 10.7.4).
I am very happy!!! Thank you so much for your hard work.

(I am a user from Thailand)

justinster123 05-19-2012 05:31 PM

Can you please add the AMD Athlon X2 7550 Processor? I have been unsuccessful every single time to get it to detect when I did it :(
Family 10
Model 2
thanks so much!

gils 05-19-2012 11:31 PM

hello,

this kernel is capable of running in 64 bit?

http://img4.hostingpics.net/pics/535...0520002847.png

davisin666 05-20-2012 02:46 AM

Quote:

Originally Posted by gils (Post 57666)
hello,

this kernel is capable of running in 64 bit?

http://img4.hostingpics.net/pics/535...0520002847.png

No, is 32 bit only (Checked with sudo ditto sudo ditto --arch x86_64 /Volumes/Lion\ HD/mach_kernel /Volumes/Lion\ HD/mach_kernel_x64, it didn't gave any output)

64 bit is harder to get it working properly, because of all the dyld/sysenter/syscall stuff.

Thanks R:A:W:X86 :D

PD: With your kernel, is necessary to have the 10.7.3 AppleFileSystemDriver.kext??? Are there the new kernel symbols???

MadMungo@iinet. 05-20-2012 08:50 AM

Hey R.A.W.X86

Tried your kernel after installing 10.7.4 combo update and have lost the ability to connect to my wireless network. Was working with the 10.7.3 kernels and 10.7.3 & lower.
I have tried reinstalling 10.7.0 with your 10.7.4 kernel and installation is ok, errors during verbose boot after install but setup ok, unfortunately the wireless card will not connect to my network. It is a failing at the WPA2 password says it has timed out.
Going back to 10.7.3 for now.

gils 05-20-2012 11:10 AM

hello ,

thank ,

http://img4.hostingpics.net/pics/585...at113208AM.png


<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Kernel</key>
<string>custom</string>
<key>Kernel Flags</key>
<string>-legacy</string>
<key>PCIRootUID</key>
<string>1</string>
<key>GraphicsEnabler</key>
<string>No</string>
<key>Boot Graphics</key>
<string>Yes</string>
<key>Quiet Boot</key>
<string>No</string>
<key>Timeout</key>
<string>5</string>
<key>npci</key>
<string>0x2000</string>
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>UseKernelCache</key>
<string>No</string>
</dict>
</plist>

ša reste vraiment faiblare !!

http://img15.hostingpics.net/pics/38...0at21735PM.png

http://img15.hostingpics.net/pics/23...at124942PM.png

http://img15.hostingpics.net/pics/84...at124937PM.png