InfiniteMac OSx86

InfiniteMac OSx86 (
-   Snow Leopard 10.6 (
-   -   Photoshop CS4 on 10.6.2 [SOLVED] (

m3s_4ev3r 12-31-2009 01:56 AM

Photoshop CS4 on 10.6.2 [SOLVED]
Hello, I finally ahve made my 10.6.2 COMPLETELY running, I installed Adobe Photoshop CS4 and on every save it crashes the program.

The bug is a 10.6 specific bug that happens to many other applications, but with the arrival of 10.6.2 the bug should be fixed, IT ISN'T. SL 10.6.2 Combo Patch is applied and I still get the same error, I tried to install a security update but it wouldn't let me, "no eligible hardware", oh joy...

Does anyone know anything about this, have YOU applied the patch and Photoshop is running as it should, being able to save and so on?

I am running:
Snow Leopard 10.6.2 + test7 kernel on:

Audio Chipset: VT1708B High Definition Audio 8-channel CODEC (dead, no hope)
AMD Athlon x2 Black Edition 7750 2.7GHz AM2+ 3MB Cache
Palit nVidia GTS 250 512MB DDR3 (works with GFX UTIL)
2x2GB GeIL Ultra DDR2 800MHz

m3s_4ev3r 12-31-2009 03:51 AM

Through lots of trial and error I think I found why the 10.6.2 on Hackintosh's doesn't fix Photoshop's behaviour.

I tested AnV's kernel for Snow Leopard, I replaced the original mach_kernel and then applied the 10.6.2 update again, the update adds like 3.6mb of information to the kernel (AnV's kernel size 15.1MB, AnV modified by 10.6.2 patch kernel size - 18.7MB).

Is it possible to move the changes in one of our custom kernels? that would fix LOTS of problems, or am I talking rubbish?

I attached the original AnV Kernel and the modded one.

AnV's original thread here:

And those are the two kernels:

xXrkidXx 12-31-2009 03:55 AM

umm if you added Andy's kernel and then updated without backing up or anything then you just updated your kernel to vanilla.(AKA Apple's kernel.) Because 10.6.2 adds a new kernel.

m3s_4ev3r 12-31-2009 03:59 AM

I have like 3-4 kernels there, when one stops I am using another one.

I am wrong then, my bad, how can I make SL run with vanilla kernel? [injection of some sort, going wild here, still learning] the idea is that if the update doesn't fix photoshop (who is updated with the latest updates) it means that the only thing unchanged is the location of the fix for it, ergo the kernel.

I am running out of ideas ...

Or how can the vanilla's kernel fixes be implemented in a custom kernel, like Andy's
THANKS, Arthur

-I am pissing against the wind here ....-

m3s_4ev3r 12-31-2009 04:05 AM

The only reason for which I switched to 10.6.2 was my graphic card, someone said that 10.6.2 is the only one who supports it.... bad choices over bad choices.

Imkantus 12-31-2009 11:51 AM

xXrkidXx is right the second Kernel is the 10.2.0 Vanilla XNU.


Originally Posted by m3s_4ev3r
how can I make SL run with vanilla kernel?

Get Intel Core- or Nehalem computer. ;)
Vanilla is the untouched OS X Kernel and doesn't work on other CPUs - at least not without beeing patched.

I guess the reason Photoshop crashes is wrong CPU Opcode. You need to patch your system using Marvin's AMD Utility again after installing Photoshop on AMD to make it work. On Leopard we have the Voodoo XNU Kernel which does this on-the-fly and doesn't require manual patching, but this feature hasn't been ported yet.

m3s_4ev3r 12-31-2009 02:05 PM

The Thing is that every time I use Marvin's AMD Patcher my sistem crashes,

When it scans System/Library it always crashes.

m3s_4ev3r 12-31-2009 08:21 PM

Problem Solved, systematically patched every binary file on my system with Marvin's AMD Utility, and EVERYTHING works, even iTunes.

for those wondering, Download Marvin's AMD Utility, don't get cpuid's from the entire system, use only option 2 and then 3, I scanned Applications and then System, and then patched everything, there were errors. When an error occurs open cpuid.txt for the directory you are patching and find the error (READ THE LOG) and delete everything until that line, including that line, save and then continue patching using option 3.

When you get to System directory, there will be encrypted files, option will also create a I entered in single user mode(I wanted to patch the cpuids from there but it didn't worked) and executed the script witch decrypted and replaced the encrypted binaries with unencrypted ones, restart and to the patching as stated above.

I hope this helps everyone who's in a tight spot!