InfiniteMac OSx86

InfiniteMac OSx86 (
-   10.X (
-   -   [GUIDE] (w/ photos) - 100% working Acer 6935g iAtkos v7 10.5.7 with nVidia 9600m GT (

Gurruwiwi 07-12-2009 08:56 PM

[GUIDE] (w/ photos) - 100% working Acer 6935g iAtkos v7 10.5.7 with nVidia 9600m GT
3 Attachment(s)
This guide is a long read, but very VERY simple. People with little experience, don't be scared to try, just be sure you have backed up all you important data as we need to have a clean HD to start with.

UPDATE 22nd September - Added Snow Leopard tutorial, check my signature

UPDATE 4th September - Snow Leopard almost running perfect (page12)

UPDATE 24TH August - Added dual boot guide Vista / Win 7 at the bottom !

UPDATE 30 June - Added forgotten Ethernet section of tutorial - added kext to attachments

It would be nice to hear success stories. Did my tutorial work for you? even if you have other laptops, if its close to this one it very well might work! So, if you dont hijack the thread, sure thing jump in and I'll do my best to help you out !

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Wow !

What an adventure I assure you.

Amazing how this laptop, with it strange, klingon-ish multimedia controller works BETTER, MUCH BETTER with OSx than with Vista/Win7 (32 or 64, tried both, 'tis the end of M$ era!) - temperature are lower, batteries last longer... bios just works better overall... amazing!

My very first, 100% working hackintosh. Actually a really good hackbook pro clone! Had a couple before, but this one excels !

My exact model is Acer 6935g 864G32mn

Native 1366x786 resolution !

3Gb/s sata transfers (not 1,5 bottleneck like new macbooks heheh)

4gb of Ram at 1066mhz

9600m GT 512ram Gddr3 with full QE /CI, ext monitors, vga + hdmi

e-sata ok !


Sd Card reader



IR port is present, but have no remote to test. Tried with a Mac remote, but obviously it wouldnt work (IR codes different) - going to try a universal remote or buy an official acer one....

Sleep kind of quirky (but I dont use it ever, but only hangs after long sleep), but good hibernation!

So let get started... (single boot)

- from USB I loaded up iAtkos v7
- With disk utility choose HD and partion with 1 partition again (essential so as to not only erase drive, but to erase bootloader info from previous try outs. I've been at this non stop for two weeks! did over 15 instals os Leo and Snow Leo.)
- Customize with;

iAtkos essential system
Bootlader - Chameleon 2
x86 Patches - Extra, DSDT, Decrypter (Apple Decrypt), AppleSMBIOS by Netkas, ACPI x86 ACPI, Disabler

VGA - NO STRINGS JUST YET! - But please do choose BOTH NVEnabler 0.1 (by fassl) + GT200 EVGA driver
Installing Leo was very easy, this video card sure was another story...

Drivers - system - Sata - AHCI (check in bios that it is set to AHCI and not IDE)

Intel Speedstep - both
Apple PS/2
Laptop Battery
Broadcom 43xx - (go on ebay and buy a 10€ model 1390 or 1490 Dell/Broadcom wireless PCI-e for native Airport)

Post install actions.

Install ! :)

Skip verify if you trust (know) your DVD / USB is ok to save time.

At the end, reboot, create your account.

Because there is love in the air, you need not make hex files and hunt down horrible efi strings and edit files hidden far in the depths of your system. Just download my herein attatched and just replace it in Library/Preferences/SystemConfiguration.

If anyone needs an efi string to try for themselves on another laptop, just download it and open with text edit. At the bottom there is a "<key>device-properties</key>" line, right after that, the huge pile of numbers and letters is the string.

This string is for Nvidia 9600m GT with 512 ram and with --> PciRoot(0x0)/Pci(0x1,0x0)/Pci(0x0,0x0)

Much more important than ram or exact model, is the PciRoot !! without it, injectors cannot talk to graphic card !

So, if my does not work for you (people other than acer 6935g) - use gfxutil method to make a in.plist and convert it ti hex (gfxutil again), copy string to your Custom Efi String, OSxTools did NOT work for me!

So back to tutorial... once you have copied over the previous one, reboot and say hello to QE/CI and everything else!.

Now for the "fun" part. I have another laptop running ideneb, where I have my 1490 Broadcom wireless. All happy and dandy I went to swap them out, and LOOK ! Its not soldered, but I dare NOT take those screws out! They MUST be superglued or semi-rivetted I dont know! Just got confirmation that they are just quite tight, mine must be super extra tight. The pci-e wifi card is NOT soldered NOR rivetted)

Then I noticed that right next to it there was anther pci-e slot !!! WOW COOL

Dropped in the card, the #%"$& wireless connectors do not reach the terminals! AAAAARG !!!!

But then, when anxiety dropped, the light bulb lit in my brain. There had to be some logic behind it. So yea, just carefully disconnect the wifi, pull the cables back into the chassis, with a tool get them out from their brackets and holders, gentley place it over the HDD. There is but 1 piece of tape holding, so I used it to secure the cables to the HDD aluminum protector.

Connect connectors.

Power up and enjoy native airport.

For ETHERNET -> Install (with OSXtools) AttansicL1eEthernet.kext that is attatched also... It should wake up after 30 seconds without reboot. First time something like that ever happened to me but it did! Otherwise, reboot and it will be there.

Using OSX tools, install the OSSDHCIblockdevice kext - this is for SD card. Reboot. If SD card does not work at first, you need to do the folloing. At the top menu bar (after you insert SD card) an icon appears having 3 or 4 instances of the card. Select "poer off" on all of them. The icon dissapears. Do not remove SD card. Reboot. The card should show up, and start working normally. If not, repeat procedure for same/other SD cards.

Multimedia touchpad controls Front Row !!

What can I say, happy as a bunny.

If you succeed or have any issues, jump in and I'll do my best !

************************************************** ********************
************************************************** ********************
************************************************** ********************
************************************************** ********************
Dual booting, people think its a problem but it is NOT, you only have to understand how play with bootloaders and active partitions.

Install Osx first, install Vista/Win7 second, this will "break" OSx booting, dont worry. Vista has set its partion as active.

If it gives an error at the end, its normal.

Insert Vista DVD and choose repair option, when it looks for OS, dont let it automatically fix, go to the next menu and choose the command prompt.

In command prompt type

"diskpart" - without the "" of course, just to let you know the sequence. Press enter

"list disk" - this shows all disks present.

"select disk X" - where X is the numer 0, 1, 2 whatever. See the number of your Leo/vista install.

"list partition" same procedure as before. See number of your Leo install

"select partition X" - where X = Leo partition

"active" - press enter

"quit" - just to be nice and tidy. Not really necessary


Now you'll have Chameleon showing both partition on boot.

If by any chance when you reboot you get an error, insert iAtkos DVD and ONLY select Chameleon 2 and Post Action. This of course to the destination of your Leo and NOT Vista/Win7 partition

Reboot and you should be able to go into Microcrap Vomit, or Winsh*t 7.

************************************************** ************************

SoundForSoul 07-18-2009 05:12 AM

It definetly works !!!
I did everything that you said, and IT WORKS like a charm!. Installed it on the same 6935g model, had another partition with xp, and now it dual boots falwlessly, just that i have to change it form bios into ide mode whenever i want to enter windows, and ahci mode whenever i wanted to enter leopard. Many thanks for this tutorial !!
Now i just have to add the strings for the graphic card.

mcdond 07-18-2009 03:20 PM

Is there any reason to install iAtkos from a usb drive rather then a dvd disk ?

Im installing it now so fingers crossed x

mcdond 07-18-2009 04:18 PM

I am completley new to all this :(

Ive tried Ideneb and also iATKOS but no matter what after I get past the first install stage my laptop restarts and just stays on the Grey Apple logo forever :(

Ive tried with ACPI and IDE mode and i get the same response.

Any ideas ?

Gurruwiwi 07-18-2009 07:27 PM

Hey !!

Yes - USB is much better because it is way faster than DVD, so if something goes wrong, you waste half the time re-installing etc... Also, for more advanced users, you can patch Chameleon/ Retail with custom stuff without having to burn a new DVD.

For instance... I installed iAtkos v7, then Snow Leopard, but then I changed my mind and re-installed iAtkos. With the same USB I did this al this in under two hours.

Mcdond ;

- When you insert DVD/USB, did you format your OSX destination drive with GUID partition table and HFS+ Journaled format ?

- Did you reach the Install section, or does it stay forever AFTER install ? If this is the case, did you get the forbidden sign, or does it just hang with the apple log and the circle going round and round ?

- Sound for Soul ... you can try and copy the boot.ini file from you leopard install into the root of the XP install. This file is hidden, so you have to do the following (very quick terminal trick)

flag it "FALSE" when you are done, if you want....

Chameleoon 2 should be able to boot MBR (partition scheme for general XP installs), you shouldnt have to change in BIOS. Either that, or, I think, use a XP that has SATA drivers! The newer XP's have this, older one's dont. From your symptom, I suspect it is XP that cannot read SATA, and you really shouldnt have to go in BIOS to dual boot.

But try copying the boot file. If Chameleon reads it, I am almost certain it will boot.

AAAHH !! Also Sound for Soul, ... if you copy my, the string is already inside!! you dont have to do it, just copy it !

The file is ONLY a custom with my (6935g specific) nvidia string, nothing else. Either it wakes up your card, or does nothing at all. No risks, so you dont even have to back up you origial file. At best, edit the file, remove the string, and you revert back to a custom install non-efi-stringed file.

Hope this helps!!

Gurruwiwi 07-18-2009 07:34 PM


Originally Posted by mcdond (Post 29598)
I am completley new to all this :(

Ive tried Ideneb and also iATKOS but no matter what after I get past the first install stage my laptop restarts and just stays on the Grey Apple logo forever :(

Ive tried with ACPI and IDE mode and i get the same response.

Any ideas ?

Sorry, didnt read correctly...

Did you

1 - format the drive GUID + hfs journalled ?
2 - did you customize the install right before clicking "install" with the setting above?

if you did, when Chameleon displays the countown bar before botting, press any key, the countdown bar with dissapear.

write " -v " .... it will appear in the lower left corner. Press enter. This is called "booting in verbose mode" - Where you see line by line each kext and code booting the system.

Take a picture of the error screen / KP (kernel panic) and post. Also try booting with

-v -f

Sometimes the system can kernel panic once or twice but boot only the third and be very stable! the "f" flag ignores the extension.mkext (a cache version of all you kexts) and rebuilds the file, so it could cure some issues.

You must have chosen some wrong or extra custom setting, if you have the same model as me. Post you exact model ! sometime, just 1 piece of hardware that is different is sufficient to prevent the system from booting.

There are many Acer 6936g with nvidia 9600m GT 1GB with DDR2.... if this is the case
my will likely not work for you!

but then again, it very well could if PCI roots info is the same... so do post you most complete specs

Xiloa 07-18-2009 08:27 PM

Hi, I've used your guide with a few mods on my 6930g and it's working great! Thanks a lot. Right now I don't have internet as the 5100 doesn't have support. I just have two quick questions for you.

1. Did you get your mic to work? I have audio and webcam support right now, it shows up that I have a mic but doesn't detect when I talk... I'm using VoodooHDA

2. I was able to take a broadcom wireless card from an old laptop that I know works in Leopard. Trouble is I don't know how to put it into this one. Its a small square with a wire attached to it that plugs into the motherboard. I was hoping to put this in my laptop and get wireless working.

Thanks! :)

Gurruwiwi 07-18-2009 08:44 PM

Hi Xiloa!

I must confess that the tittle says 100% but in reality it should read 96%... ( it WILL be 100% soon, that is my mission !!! )

I am currently working on the same sound issue. It is a must for me, as I work alot with audio and it sure is handy to have the internal mic working. (plus skype and stuff)

I dont think the external mic in os working either. But I am getting down into this issue, have to test some edits and I will post. Any info is very welcome!

I also experience some click and pops ons some video encodings. Changing system frequency to 48k work some times, but the soundcard does not show up in system profile.

I am sure I have to string it to... that is my next project, but unfortunately not for this weekend. Installed Protools 8 (with mbox 2) and it rocks. So does Reason 4. Its just some video's with stranger encodings that act up.

Also, since yesterday, with no apparant change in system, when shutting down, right before power off, the speaker make a mild "pop" sound.

I will report soon on this.

Also, I am going to try re-installing again without choosing the broadcom driver. Vanilla kernel has airport, and although wifi is 100% working, it shows up as "third party vendor".

Are you sure your broadcom card is in pci-e format? It is as simple as changing Ram, except here you dont even have to remove the older one, there is an extra slot. Check my pictures. It is just slide in, screw it in tight, connect cables and that is it.

It should be 100% native, so I am guessing I shouldnt have tried that driver. No big issue. All apps and programs read correct info, but I really want the closet thing to the real deal.

Xiloa 07-18-2009 09:11 PM

Hmm well the card appears to not be PCIe. Ah well..I do have a TrendNet TEW-424UB wireless stick based on the 8187b. It works great but it always overheats after about an hour and causes Leopard to crash instead of simply disconnecting. Thanks for the info on the mic. I might have to wait for a 5100 driver :-/

Gurruwiwi 07-19-2009 01:54 AM

Not likely to happen I'm afraid.

Really, can't go wrong with 1390 or 1490 Dell/Broadcom from ebay. They run about 5-25 faultDomain_0?hash=item33539623bf&_trksid=p3286.c0 .m14&_trkparms=65%3A12|66%3A2|39%3A1|72%3A1315|293 %3A1|294%3A50