InfiniteMac OSx86

InfiniteMac OSx86 (
-   10.X (
-   -   The "Unofficial" Empire EFI Support Thread (

prasys 11-30-2009 02:43 PM

The "Unofficial" Empire EFI Support Thread
Hey Guys

I thought of making this forum a bit cleaner by starting official Empire EFI Support Thread. since the other forum decided to do censorship (hooray for the Great Wall of Censorship) . I've decided to come here and start a support thread. Its a mutual relationship , as in InfiniteMac would get more users and in return I can get to seek peoples opinion , and reduce the number of e-mails I get about it.

I do hope that the administrators wouldn't mind if I start a topic here. If a written consent is needed , I'm sure to write it in more

anyway , so go on , spur your problems or what-so-ever that we are facing to improvise it and make it easier for people to use Empire EFI !


jmacie 11-30-2009 04:15 PM

Prasys, Thanks!
I have been partially successful with empire efi. I use ati, and am just understanding the elements of staying the choice of ati. I succeeded with v1.7 and ati x1600 and 10.6.0 + your upgrade to 10.6.2! I've spent 126 hours trying to use other ati cards with snow leopard, failing with yours and Netkas' info and guides. I understand more on kexts thanks to you for your blog, but don't understand enough to make hd3650 work outside of 10.5.8 or hd4670 work in snow leopard. I'm not asking you for a hardware solution other than direction to a forum or irc. Please understand that as a neophyte that's trying to learn on my own, that #radeonhd irc and insanelymac are less than understanding or helpful. Thank you jmacie

monsteroyd 12-01-2009 03:21 AM

I get the memory allocation error. Should I try the older version?


InteliMacPro 12-01-2009 07:25 AM

I had great success with the hardware in my sig. Only thing was i had no video using the gtx260 so i had to put in my old 8800gs for the install and then swap in the gtx260 and follow PCwiz's guide to get it working. If we can find a way to get the gtx260 working in vesa for the install it would be awesome. Swapping it out sucks.

prasys 12-01-2009 07:27 AM

@ jmacie - you'll have to follow netkas' guide and get his bootloader. I can't be much help as I don't know much of how these 4xxx series card do work exactly.

@ monsteroyd - try version 1.01 instead

@ InteliMacPro - I'll try to see if i can get VESA to work with gtx2xx series. Nvidia would be pretty stupid if they removed vesa support for it. I'll see if i can get some tricks to make it to work in VESA.

InteliMacPro 12-01-2009 07:48 AM

That's awesome prasys, thanks! Just wanted to add that the version I used was the beta for the X58 chipset and not v. 1.08 which may have worked with my gtx 260 from the sound of it. I might download the new version tomorrow and try an install on a separate partition just to see if it works. I wanted to do this anyway to make fixing issues like the sleepenabler.kext issue after updating to 10.6.2 easier. The version I had was what was up a week or so ago.

RetroRen 12-01-2009 08:38 AM

I tried EE (AMD version), and got Still waiting for root device error when booting OSX SL 10.6 DVD.

Then I tried booting DVD with -v -f -s -x and I got KP sayin' somethin' about pmap_memory_steal.

Guess it's kernel thats bugging me or?

Specs are in the sig.

pαuℓzurrr. 12-01-2009 09:26 PM

Having the problem where SuperNForceATA wouldn't load correctly, leaving me with a still waiting error.
Hope you could rebuild the image with a 'proper' kext?

anteo 12-01-2009 11:33 PM

Hi, I have just bought an i7/P55 intel system, it will be shipped on friday.

Is it possible to use Empire EFI on such system, for what I understood it goes only on X58 platforms. Is it right?


ULTIMATI 12-02-2009 03:30 AM

i have download the empire EFi iso..unfotunately the booting always restart it self after mounting doned...did i do something wrong...i have retail snow leopard purchased from store $50sgd...

so plz u guy give a very workin empire efi please..

my spec..
AMD Turion x2
ATi Radeon HD4200
Atheros AR5B93
AR8131 Gigabit Lan

sucessful install with ideneb 10.5.8 with workin soundcard but with weird sound..except wifi,and ethernet not workin..Like to try SL...

i just need very working Empire EFI...!!!