InfiniteMac OSx86

InfiniteMac OSx86 (
-   Leopard 10.5 (
-   -   Atheros card 9285 (

hellboy 02-08-2010 12:39 PM

CarryDude, you should try to put the CountryCode and Locale not at the end of the file, but just before the end :



I'll try it tonight and repost some result.

hellboy 02-09-2010 11:29 AM

I am trying modifying the info.plist from the AirportAtheros21 kext.
But my IORegistry show me APAC as Locale and nothing as CountryCode.

What means FCC ? 'cause i'm in france, so i can't use FCC/US

remisenforme 02-09-2010 04:51 PM

Hello everyone, I too have the same point.
Ar9285 recognized but no network.
I compared the Airport System Profiler on my Mac Mini (original) with that of Snow/Asus: my countrycode IT, locale ETSI, I suppose because I'm in Italy.
I tried unsuccessfully changes to the kext as indicated by Hellboy ..
if someone gives me more information I can try ..
Great job everyone!

hellboy 02-09-2010 07:39 PM

So, i tried what CarryDude said :
it doesn't work for me, but i tried different thing :
i saw an other IOProviderClass key in the file, so I put the dict section just below.
but it break the kext, i couldn't load it.
so i tried to put only locale and country code below the IOProviderClass, and I get the same result as CarryDude said.

So I will continue to try different thing.

xpack 04-22-2010 05:50 AM

Did anyone ever get this card working?

scififan68 04-22-2010 01:24 PM

You could try something like: but it's risky. But if successful it may work because I'm lead to believe the iMac11,1 has something close to these cards.
From sys profiler dump:

Type: Other Network Controller
Bus: PCI
Vendor ID: 0x168c
Device ID: 0x002a
Subsystem Vendor ID: 0x106b
Subsystem ID: 0x008f
Revision ID: 0x0001
Link Width: x1
someone was able to get it working.
Card Type: AirPort Extreme (0x168C, 0x8F)
Firmware Version: Atheros 9280:

alexylee 04-24-2010 12:59 PM

Has some one tried madwifi from Liunx?

ushio81 05-20-2010 11:33 AM

Any news with the 9285 card?
I've installed Snow Leopard on my 1005HA but still my wireless card isn't shown up under the hardware info...

Bambo 06-17-2010 02:53 AM

It's not the problem of IO80211Locale
I've patched the binary and now and
IO80211Locale is set to FCC, But the card can't work yet.

uwannacookie 07-28-2010 12:03 AM

I'm working on country codes and locales. Once again , THEY ARE YOU EARS ! You have to put the country stuff at yours. Mine's locale is ISO3166 and Country Code is PT. but i'm still putting this on working.