InfiniteMac OSx86

InfiniteMac OSx86 (
-   Leopard 10.5 (
-   -   Atheros card 9285 (

bandit250 10-15-2009 01:22 PM

Atheros card 9285
can any one help me with finding the kext for this card?

flip360 11-11-2009 08:05 PM

try 10.6.2 update :)

marchele 11-13-2009 10:46 PM

Atheros AR9285
So, the AR9285 work? can you post the kext? thanks!

flip360 11-13-2009 10:51 PM

I have had the AR9285 WiFi card and it was recognized with the 10.6.2 update (just have to put your device-id in Atheros21.kext), airport is recognized but its not scanning or connecting to any network..I swapped it yesterday with a Dell 1490 and it showed up as native airport Brcm43xx, scanned and connected to networks immidiately, so i have to say that the Atheros card is still not working... :(

scififan68 11-14-2009 08:13 AM

Try this kext:

Imkantus 11-14-2009 08:46 AM

There are various people around, who have reported this card not to work with new AirPortAtheros21.kext ...

I just wanted to let you know that netkas released a legacy kext that injects the Device-ID, so that you don't need to edit the Kernel Extension itself. :)

meistersinger 11-14-2009 09:52 AM

Installing Snow Leopard on an ECS Elitegroup Nvidia MCP-61 chipset motherboard
I have the following hardware:

ECS Elitegroup motherboard with nVidia MCP61 chipset (with latest Award BIOS installed)
2 GB Memory
AMD 64x2 5200+ cpu
eVGA Geforce 6200 PCIe Videocard
TI-based Firewire 400 card.
2-Hitachi 1tb SATA Hard drives
2-Maxtor 500gb SATA Gard drive
1 Seagate 500 IDE hard drive
1 LiteOn 24x DVD burner

I have tried, without success, to install Snow Leopard on this machine
using the methods found 1), 2) on prasys' blog and 3)the methods outlined all over the web on installing snow leopard to a USB flash drive, as well as a small partition on a second hard drive while running under leopard.

Each method always ends the same way. I end up with a type 14 error and the system does a panic and coredump. I have used modbin's test7 kernel, as well as qoozl with the same results. I have tried Chameleon 1.1, 2.0rc1, 2.0rc2, and 2.0rc3 with the same results. I have also installed the latest NForceATA kexts, Latest NVIDIA video injector kexts and the latest dsmos kexts in ~/Extra/Extensions, rebuilt the Extensions cache under ~/Extra, and still get the same results.


a very frustrated meistersinger.

Imkantus 11-14-2009 10:01 AM


Originally Posted by meistersinger (Post 39392)

You're posting in the wrong forum into a topic with a different subject.

CaryDude 12-19-2009 05:20 AM

A little less "hack", a little more science?
So everybody wants to get this card going under Snow Leopard, but we're not really getting to the root of the problem, just throwing kexts at each other.

My System Profiler shows the card with an unknown locale and no country code.

That shouldn't be. We can see in IORegistryExplorer where that's coming in.

There's been numerous discussions on Apple's site (like ) where folks' country codes aren't being detected right on 802.11n cards under Snow Leopard. What's supposed to happen is that the card listens to hear the beacons of access points in the area, and determines what the IO80211Locale and IO80211CountryCode are by picking them out of beacons it hears. Supposedly Apple (ok, Atheros) fixed those issues in the 10.6(2) release that gave us the Atheros support to begin with, but I still see this in my kernel log:

So being a creative guy, I tried modifying the Info.plist file and adding this in at the end of the file:



But they ended up at the wrong level, appearing on the AirPort_AthrFusion21 not the AirPort_AthrFusion21Interface where they need to be.

Somebody good with plists might be able to help us force this, but I think what's really needed is somebody who understands the interaction between the driver and the hardware. We can all flip the Airport off and on, so we're waking it up, but it's ears aren't listening. Once we figure out how to make the ears open up, they'll hear the beacons they're supposed to, figure out what locale and country code to use, and we'll be beyond this (and on to figure out the darned AttansicL1E ethernet card--which, I think, is having similar issues on the transmit side.)

collac432 01-04-2010 02:14 PM

I completely agree with CaryDude
I've been searching for info about this problem since a long time ago, and what CaryDude says is the better explanation i've readed.

I would like to have more knowledge on how kexts and hw interact, but is not the case :(

I hope somebody can help us.


hellboy 02-08-2010 12:39 PM

CarryDude, you should try to put the CountryCode and Locale not at the end of the file, but just before the end :



I'll try it tonight and repost some result.

hellboy 02-09-2010 11:29 AM

I am trying modifying the info.plist from the AirportAtheros21 kext.
But my IORegistry show me APAC as Locale and nothing as CountryCode.

What means FCC ? 'cause i'm in france, so i can't use FCC/US

remisenforme 02-09-2010 04:51 PM

Hello everyone, I too have the same point.
Ar9285 recognized but no network.
I compared the Airport System Profiler on my Mac Mini (original) with that of Snow/Asus: my countrycode IT, locale ETSI, I suppose because I'm in Italy.
I tried unsuccessfully changes to the kext as indicated by Hellboy ..
if someone gives me more information I can try ..
Great job everyone!

hellboy 02-09-2010 07:39 PM

So, i tried what CarryDude said :
it doesn't work for me, but i tried different thing :
i saw an other IOProviderClass key in the file, so I put the dict section just below.
but it break the kext, i couldn't load it.
so i tried to put only locale and country code below the IOProviderClass, and I get the same result as CarryDude said.

So I will continue to try different thing.

xpack 04-22-2010 05:50 AM

Did anyone ever get this card working?

scififan68 04-22-2010 01:24 PM

You could try something like: but it's risky. But if successful it may work because I'm lead to believe the iMac11,1 has something close to these cards.
From sys profiler dump:

Type: Other Network Controller
Bus: PCI
Vendor ID: 0x168c
Device ID: 0x002a
Subsystem Vendor ID: 0x106b
Subsystem ID: 0x008f
Revision ID: 0x0001
Link Width: x1
someone was able to get it working.
Card Type: AirPort Extreme (0x168C, 0x8F)
Firmware Version: Atheros 9280:

alexylee 04-24-2010 12:59 PM

Has some one tried madwifi from Liunx?

ushio81 05-20-2010 11:33 AM

Any news with the 9285 card?
I've installed Snow Leopard on my 1005HA but still my wireless card isn't shown up under the hardware info...

Bambo 06-17-2010 02:53 AM

It's not the problem of IO80211Locale
I've patched the binary and now and
IO80211Locale is set to FCC, But the card can't work yet.

uwannacookie 07-28-2010 12:03 AM

I'm working on country codes and locales. Once again , THEY ARE YOU EARS ! You have to put the country stuff at yours. Mine's locale is ISO3166 and Country Code is PT. but i'm still putting this on working.

uwannacookie 07-28-2010 12:46 AM

After many testing and not getting my country codes on... I can say this wifi works. BUT , you need to set up your country code and locale .

Someone who got USA/FFC on country stuff , make another IO80211Family.kext with these stuff:

Locale: ISO3166
Country Code: PT

if it made successfully , gimme link to test it. I know this card works , but you know , he needs to know where it is. If it doesn't know , it will show up Unknown and will not connect to anything. Those country settings defines to your card on what it can connect or can't.

I hope you make it quickly , to check if it is alright, if positive , make for worldwide .

questionmark425 08-02-2010 07:47 PM

I would be glad to try that out.
I have that card installed and recognized in system profiler, and am in the US. If you would tell me where in the plist I will have to enter this information I would be glad to give it a shot.

uwannacookie 08-06-2010 10:55 AM

You have to enter some stuff at the bottom of the first page , but for me, no work.

azncheng 08-16-2010 08:17 PM

ar9825 working in 10.6.5
so supposdly ar9285 works with 10.6.5 beta right now with this legacy atheros kext it in chinese...need free register to download. just click "入住远景" enter preffered username..password..retype and code..and youre good to go!

...i just got 10.6 on my eeepc1008ha after a frustrating im kind of reluctant to update to 10.6.5...but the kext file doesn't work with my 10.6 T_T just detects it as ethernet adapter.

azncheng 08-16-2010 11:36 PM


Originally Posted by azncheng (Post 50103)
so supposdly ar9285 works with 10.6.5 beta right now with this legacy atheros kext it in chinese...need free register to download. just click "入住远景" enter preffered username..password..retype and code..and youre good to go!

...i just got 10.6 on my eeepc1008ha after a frustrating im kind of reluctant to update to 10.6.5...but the kext file doesn't work with my 10.6 T_T just detects it as ethernet adapter.

i uploaded it on media fire

bellbottom 08-18-2010 12:36 AM

At Last Atheros 9285 working
Congratulations for al the users were waiting a lot of time ofr a solution.
Now my Atheros 9285 wifi card is working.


glass330 08-31-2010 06:11 PM

I have tested the legacyatheros.kext on my Asus 1005hab and it does work. I install the kext with kexthelper B7, repair permissions, then restart and it works great. As soon as i restart the system a 2nd time, it never works again unless I remove the kext and repeat the above steps.

What can I do to make this work after restarting?

it does this in 10.6.3, 10.6.4, & 10.6.5 beta

what am i doing wrong?

thank guys

Ugokind 01-29-2012 05:34 PM

what about the internal BT module .. and the Coexistence function that could be only enabled in Windows?