InfiniteMac OSx86

InfiniteMac OSx86 (
-   Leopard 10.5 (
-   -   Atheros card 9285 (

bandit250 10-15-2009 01:22 PM

Atheros card 9285
can any one help me with finding the kext for this card?

flip360 11-11-2009 08:05 PM

try 10.6.2 update :)

marchele 11-13-2009 10:46 PM

Atheros AR9285
So, the AR9285 work? can you post the kext? thanks!

flip360 11-13-2009 10:51 PM

I have had the AR9285 WiFi card and it was recognized with the 10.6.2 update (just have to put your device-id in Atheros21.kext), airport is recognized but its not scanning or connecting to any network..I swapped it yesterday with a Dell 1490 and it showed up as native airport Brcm43xx, scanned and connected to networks immidiately, so i have to say that the Atheros card is still not working... :(

scififan68 11-14-2009 08:13 AM

Try this kext:

Imkantus 11-14-2009 08:46 AM

There are various people around, who have reported this card not to work with new AirPortAtheros21.kext ...

I just wanted to let you know that netkas released a legacy kext that injects the Device-ID, so that you don't need to edit the Kernel Extension itself. :)

meistersinger 11-14-2009 09:52 AM

Installing Snow Leopard on an ECS Elitegroup Nvidia MCP-61 chipset motherboard
I have the following hardware:

ECS Elitegroup motherboard with nVidia MCP61 chipset (with latest Award BIOS installed)
2 GB Memory
AMD 64x2 5200+ cpu
eVGA Geforce 6200 PCIe Videocard
TI-based Firewire 400 card.
2-Hitachi 1tb SATA Hard drives
2-Maxtor 500gb SATA Gard drive
1 Seagate 500 IDE hard drive
1 LiteOn 24x DVD burner

I have tried, without success, to install Snow Leopard on this machine
using the methods found 1), 2) on prasys' blog and 3)the methods outlined all over the web on installing snow leopard to a USB flash drive, as well as a small partition on a second hard drive while running under leopard.

Each method always ends the same way. I end up with a type 14 error and the system does a panic and coredump. I have used modbin's test7 kernel, as well as qoozl with the same results. I have tried Chameleon 1.1, 2.0rc1, 2.0rc2, and 2.0rc3 with the same results. I have also installed the latest NForceATA kexts, Latest NVIDIA video injector kexts and the latest dsmos kexts in ~/Extra/Extensions, rebuilt the Extensions cache under ~/Extra, and still get the same results.


a very frustrated meistersinger.

Imkantus 11-14-2009 10:01 AM


Originally Posted by meistersinger (Post 39392)

You're posting in the wrong forum into a topic with a different subject.

CaryDude 12-19-2009 05:20 AM

A little less "hack", a little more science?
So everybody wants to get this card going under Snow Leopard, but we're not really getting to the root of the problem, just throwing kexts at each other.

My System Profiler shows the card with an unknown locale and no country code.

That shouldn't be. We can see in IORegistryExplorer where that's coming in.

There's been numerous discussions on Apple's site (like ) where folks' country codes aren't being detected right on 802.11n cards under Snow Leopard. What's supposed to happen is that the card listens to hear the beacons of access points in the area, and determines what the IO80211Locale and IO80211CountryCode are by picking them out of beacons it hears. Supposedly Apple (ok, Atheros) fixed those issues in the 10.6(2) release that gave us the Atheros support to begin with, but I still see this in my kernel log:

So being a creative guy, I tried modifying the Info.plist file and adding this in at the end of the file:



But they ended up at the wrong level, appearing on the AirPort_AthrFusion21 not the AirPort_AthrFusion21Interface where they need to be.

Somebody good with plists might be able to help us force this, but I think what's really needed is somebody who understands the interaction between the driver and the hardware. We can all flip the Airport off and on, so we're waking it up, but it's ears aren't listening. Once we figure out how to make the ears open up, they'll hear the beacons they're supposed to, figure out what locale and country code to use, and we'll be beyond this (and on to figure out the darned AttansicL1E ethernet card--which, I think, is having similar issues on the transmit side.)

collac432 01-04-2010 02:14 PM

I completely agree with CaryDude
I've been searching for info about this problem since a long time ago, and what CaryDude says is the better explanation i've readed.

I would like to have more knowledge on how kexts and hw interact, but is not the case :(

I hope somebody can help us.