InfiniteMac OSx86  


Reply
 
Thread tools Display modes
  #1  
Old 08-14-2012, 12:20 AM
lapendulum lapendulum is offline
Cheetah
 
Join Date: Jul 2012
Posts: 3
Question 10.7.3 AMD FX 4100 - Flash Player won't install

Every time I launch the installer, I will get a message saying, "adobe flash player quit unexpectedly" and it's really the only thing keeping me from enjoying my hackintosh.

Some other apps won't work like the dvd player but I'm not concerned with that.

The graphics drivers I installed are correct, transparent menu bar and the water ripple effect work.
So I don't think it is a graphic related issue?

My Processor is an AMD FX 4100
MotherBoard is 990FXA-UD5
GraphicsCards(2) are GTX 560 ti
16gigs of ram

Error report for launching flash player:
Code:
Process:         Adobe Flash Player Install Manager [1861]
Path:            /Volumes/VOLUME/Install Adobe Flash Player.app/Contents/MacOS/Adobe Flash Player Install Manager
Identifier:      com.adobe.flashplayer.installmanager
Version:         ??? (???)
Code Type:       X86 (Native)
Parent Process:  launchd [124]

Date/Time:       
OS Version:      Mac OS X 10.7.3 (11D50)
Report Version:  9

Interval Since Last Report:          7365 sec
Crashes Since Last Report:           723
Per-App Crashes Since Last Report:   5
Anonymous UUID:                      

Crashed Thread:  0

Exception Type:  EXC_BAD_INSTRUCTION (SIGILL)
Exception Codes: 0x0000000000000001, 0x0000000000000000

Thread 0 Crashed:
0   dyld                              0x8fe3138d _sysenter_trap + 3
1   dyld                              0x8fe0d1e6 dyldbootstrap::start(macho_header const*, int, char const**, long, macho_header const*) + 372
2   dyld                              0x8fe0d063 _dyld_start + 51

Thread 0 crashed with X86 Thread State (32-bit):
  eax: 0xffffffe4  ebx: 0x00000002  ecx: 0xbffffc5c  edx: 0x8fe30b8a
  edi: 0x0000c000  esi: 0x8fe30a05  ebp: 0xbffffc68  esp: 0xbffffc5c
   ss: 0x0000001f  efl: 0x00010246  eip: 0x8fe3138d   cs: 0x00000017
   ds: 0x0000001f   es: 0x0000001f   fs: 0x00000000   gs: 0x00000000
  cr2: 0x8fe3138a
Logical CPU: 0

Binary Images:
0x8fe0c000 - 0x8fe3eaa7  dyld (195.6 - ???) <3A866A34-4CDD-35A4-B26E-F145B05F3644> /usr/lib/dyld

External Modification Summary:
  Calls made by other processes targeting this process:
    task_for_pid: 1
    thread_create: 0
    thread_set_state: 0
  Calls made by this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
  Calls made by all processes on this machine:
    task_for_pid: 1123
    thread_create: 0
    thread_set_state: 253

VM Region Summary:
ReadOnly portion of Libraries: Total=280K resident=188K(67%) swapped_out_or_unallocated=92K(33%)
Writable regions: Total=8368K written=12K(0%) resident=20K(0%) swapped_out=0K(0%) unallocated=8348K(100%)
 
REGION TYPE                      VIRTUAL
===========                      =======
Stack                              64.0M
VM_ALLOCATE                           4K
__DATA                              172K
__LINKEDIT                           76K
__TEXT                              204K
mapped file                         200K
shared memory                        12K
===========                      =======
TOTAL                              64.7M
Reply With Quote
  #2  
Old 08-17-2012, 08:55 AM
R:A:W:X86's Avatar
R:A:W:X86 R:A:W:X86 is offline
 
Join Date: Mar 2012
Location: Germany
Posts: 95
Use the latest Kernel I compiled (should also work on Lion pre-10.7.4 - whyever you are still using it) & patch sysenter traps for 32-Bit Apps to work.

AMD FX 4100
MSI 760GM-P23
Radeon HD6570
OS X Lion Retail 10.7.5
Lion Kernel Project

Last edited by R:A:W:X86; 08-17-2012 at 12:00 PM.
Reply With Quote
  #3  
Old 08-20-2012, 03:55 PM
lapendulum lapendulum is offline
Cheetah
 
Join Date: Jul 2012
Posts: 3
Quote:
Originally Posted by R:A:W:X86 View Post
Use the latest Kernel I compiled (should also work on Lion pre-10.7.4 - whyever you are still using it) & patch sysenter traps for 32-Bit Apps to work.
Thanks so much!

Everything works perfect with your kernel and the apps fix


Reply With Quote