InfiniteMac OSx86  
  #1  
Old 09-14-2012, 11:40 PM
gils's Avatar
gils gils is offline
Panther
 
Join Date: Dec 2011
Posts: 194
kernel 12.0 AMD SVP ?



goodnight,

The good news is that Niresh ML 10.8 moved through OSInstall. mpkg, I tested a vein attempt with kernel RAWX86 11.4, it was expected that it will not start but I still say that the processor is recognized with the FSB, maybe a track gentlemen developers ??








Macmini early 2006 /blanGsak 10.7.2
Acer 8930 G / core2duo T6500 / NV 9600 GS m / Lion 10.7.3 / ML 10.8.2 / w7/8
Asus M5A97pro / FX 8350 / Asus HD 7950 CUII v2
GA-78LMT SP2 / FX 6100 / P x4 960t / Sapphire HD 4850 1024
MSI K9neo v1 / Atlon 4800+/ Gigabyte HD 5450 512
test kernel 12.0 AMD

Tuto : http://www.hack-my-mac.fr/index.php/...fx-buldo#28896

CG opérationnelle : HD 5450 512 / HD 4850 1 / GT 610
Reply With Quote
  #2  
Old 09-19-2012, 02:39 AM
The Connactic The Connactic is offline
Jaguar
 
Join Date: Jul 2012
Posts: 89
Hey, Gils! That's good news! I tried a different approach: tried to apply RAWX86's diff file as a patch to the 12.0 XNU, to no avail. Never thought of simply use RAWX86's 10.7.4 directly to see the results.

Follow this topic at insanelymac.com: http://www.insanelymac.com/forum/ind...owtopic=281450
Reply With Quote
  #3  
Old 09-19-2012, 02:44 AM
The Connactic The Connactic is offline
Jaguar
 
Join Date: Jul 2012
Posts: 89
P.S.: "In case you read this there has been a kernel panic
there is no ----ing support to running Lion on AMD
you have to try fixing this yourself"

Reply With Quote
  #4  
Old 09-19-2012, 11:55 AM
R:A:W:X86's Avatar
R:A:W:X86 R:A:W:X86 is offline
 
Join Date: Mar 2012
Location: Germany
Posts: 95
looks similiar as it does when you build i386 ML XNU from source and try to boot it (intel setup)....

AMD FX 4100
MSI 760GM-P23
Radeon HD6570
OS X Lion Retail 10.7.5
Lion Kernel Project
Reply With Quote
  #5  
Old 09-19-2012, 04:23 PM
The Connactic The Connactic is offline
Jaguar
 
Join Date: Jul 2012
Posts: 89
Hmm. Of course, RAW: your kernel is i386, Mountain Lion requires AMD64. I myself was making a similar mistake, trying to patch 12.0 with your diff.

We could try, as an experience unlikely to succeed obviously, to boot ML with your universal version of 11.4 and archx86_64. Just to see what happens.
Reply With Quote
  #6  
Old 09-19-2012, 05:26 PM
The Connactic The Connactic is offline
Jaguar
 
Join Date: Jul 2012
Posts: 89
Did it! No instant reboot at all. Instead:
Attached Images
File Type: jpg kernelpanicwithraw64bit.jpg (508.0 KB, 31 views)
Reply With Quote
  #7  
Old 09-19-2012, 05:29 PM
The Connactic The Connactic is offline
Jaguar
 
Join Date: Jul 2012
Posts: 89
How funny! The attached image is flipped upside down!

Anyway, notice - if you can, the photo's quality is poor, done with an iPad - the sixth line: "the mach-0 is malformed", whatever that means.
Reply With Quote
  #8  
Old 09-19-2012, 06:39 PM
R:A:W:X86's Avatar
R:A:W:X86 R:A:W:X86 is offline
 
Join Date: Mar 2012
Location: Germany
Posts: 95
For my understanding of that flipped image:
  1. it's an AMD based setup
  2. it's an installation of Mountain Lion
  3. you are trying to boot it using that Kernel: http://osx86.co/f100/10-7-4-amd-kern...post58241.html
  4. it does not result in instant reboot, while it does when using the same Kernel (x86_64) on a Lion installation
?!

AMD FX 4100
MSI 760GM-P23
Radeon HD6570
OS X Lion Retail 10.7.5
Lion Kernel Project
Reply With Quote
  #9  
Old 09-19-2012, 07:00 PM
The Connactic The Connactic is offline
Jaguar
 
Join Date: Jul 2012
Posts: 89
1) It's an AMD Athlon II X2 250, running on an ECS-A780LM-M2 motherboard, with 8 GB RAM (2x4GB 1066 kingston), booting from an USB device (yeah, i have a complete 10.8 installation on my USB stick just in case my 10.8.1 netbook suddenly fails on me);

2) Yup, Mountain Lion 10.8.0;

3) I'm using this one, upload by you (and renamed by me): http://www.xup.in/dl,21183920/universal_kernel.zip/

4) No, no instant reboot at all! A lot of messages like "Symbol not found" or something, much like when i tried to run 10.7.2 with your kernel (yes, i did it, but 10.7.2 actually boot to the desktop), then these lines "failed kext" and "mach0 is malformed", then KP.

I will upload a video of the entire process later, if you think it's useful.

P.S.: i used the following flags: raw64bit (my name for your kernel) npci=0x3000 arch=x86_64 -v
Here's the org.chameleon.plist of my USB 10.8.0, if needed:


<key>Boot Graphics</key>
<string>Yes</string>
<key>Default Partition</key>
<string>hd(0,3)</string>
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>GenerateCStates</key>
<string>Yes</string>
<key>GeneratePStates</key>
<string>Yes</string>
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>Kernel</key>
<string>custom</string>
<key>Kernel Flags</key>
<string></string>
<key>Quiet Boot</key>
<string>No</string>
<key>Timeout</key>
<string>5</string>
<key>UseKernelCache</key>
<string>No</string>
<key>npci</key>
<string>0x2000</string>

(notice it does not include the bootflags i used)

Last edited by The Connactic; 09-19-2012 at 07:51 PM.
Reply With Quote
  #10  
Old 09-20-2012, 10:29 AM
R:A:W:X86's Avatar
R:A:W:X86 R:A:W:X86 is offline
 
Join Date: Mar 2012
Location: Germany
Posts: 95
Quote:
Originally Posted by The Connactic View Post
4) No, no instant reboot at all! A lot of messages like "Symbol not found" or something, much like when i tried to run 10.7.2 with your kernel (yes, i did it, but 10.7.2 actually boot to the desktop), then these lines "failed kext" and "mach0 is malformed", then KP.
You are sure, that using the same Kernel build (x86_64) on 10.7, on the same hardware - has been causing instant reboot?

I'd rather try this experiment myself, but I don't have much time for these things atm - would be great if you could ensure this...



AMD FX 4100
MSI 760GM-P23
Radeon HD6570
OS X Lion Retail 10.7.5
Lion Kernel Project
Reply With Quote
Reply
Thread Tools
Display Modes