InfiniteMac OSx86  


Reply
 
Thread tools Display modes
  #1  
Old 03-04-2011, 05:08 PM
Fabiuzi Fabiuzi is offline
Cheetah
 
Join Date: Mar 2011
Location: Belgium
Posts: 6
ALC892 solution needed for Asus M4A89GTD PRO/USB3 mobo

Hello!

This is my first post on a osx86 subject! ^^

I have successfully installed 10.6.6 with Internet enabled and a resolution of 1400x1050 coming from my integrated Radeon HD 4290. My AMD Phenom II 3.2GHz 1090T 6 cores are enabled, but 64 bit kernel is impossible to install. However, 32 bit kernel works very nice and applications can be run in 64 bit mode. I have a Sapphire Radeon HD6950 and I know no drivers exists for this (yet :P). Runnig it on the current resolution is ok for me. The only thing I would like to enable is the audio, and for the moment I had no success. The audio present is the ALC892 chip. I tried two methods.

  1. Use the multibeast installer and choose the ALC8xxHDA method
  2. Download the VoodooHDA 2.7.2 and install this one
There is sound, but such a nasty quality I mute the volume!!

So in fact I am looking for a good guide to install them or a better driver that ensures good sound quality. I tried every method found on the web related to the ALC892 chip AND the ones related to the ALC8xxHDA method. None of them gave me a good sound quality! Also tested on both green rear port and front port without success.

Could somebody tell me their experiences with this ALC892 on my same mobo or your way to install it?

I am willing to write the driver myself! if not too difficult or enough resources are provided I don't nothing about this stuff, but I am a java developer with some basi unix skills so never say never

Btw, I love snow leopard
Reply With Quote
  #2  
Old 03-27-2011, 11:37 AM
maya77's Avatar
maya77 maya77 is offline
Panther
 
Join Date: Jun 2008
Posts: 194
Shouldn't you install VoodooHDA?

Which kernel you are using? I'm just going to install Hazard's 10.6.2 for AMD.

Should I check "Legacy Kernel 10.2.0" on options page? And Chameleon RC4?

Reply With Quote
  #3  
Old 03-27-2011, 01:25 PM
Fabiuzi Fabiuzi is offline
Cheetah
 
Join Date: Mar 2011
Location: Belgium
Posts: 6
I did install voodooHDA, but the sound is still no good. it is not acceptable. do you have an alc892 audio chpiset?

I'm using the snowleo distro (not the hazard one!) with 10.6.6 update with legacy kernel 10.6.6. for sure use the chameleon RC4, for the kernel I can't advise you as I don't know which system you have.

ciao
Reply With Quote
  #4  
Old 03-28-2011, 06:25 PM
maya77's Avatar
maya77 maya77 is offline
Panther
 
Join Date: Jun 2008
Posts: 194
I'm using legacy kernel 10.6.6. SL updated to 10.6.7.
I've the the same mobo as yours - M4A89GTD PRO/USB3.

Snow can see my processor, as "Unknown" but correct speed and all six cores (AMD Phenom II X6 1090T). It can also see all of my RAM - 16GB DDR2. GTX460 is working at full speed and resolution.

Here are my current problems:
- System won't run without -force64 flag
- No audio (tried with both, voodoohda and alc892 kexts)
- I'm not able to run Kext Utility
- Firefox and Safari are freezing often
Reply With Quote
  #5  
Old 03-28-2011, 07:12 PM
Fabiuzi Fabiuzi is offline
Cheetah
 
Join Date: Mar 2011
Location: Belgium
Posts: 6
if you don't have the snowleo distro I can't help you...
for the audio, if you use voodoohda272 it will work with snowleo distro

AMD Phenom II x6 3.2 GHz 1090T 같같 Sapphire Radeon HD 6970 2GB DDR5 (BIOS 6950) 같같 Corsair Dominator 4 x 4GB RAM 1.6 GHz DDR3 XMP (CMP8GX3M2A1600C9) 같같 Windows 7 Ultimate 64bit
Reply With Quote
  #6  
Old 08-19-2011, 11:52 AM
oslen oslen is offline
Cheetah
 
Join Date: Aug 2011
Location: Germany
Posts: 1
I have the same mobo (M4A89GTD PRO/USB3) and processor (AMD Phenom II X6 1090T) i am running SL 10.6.8 with legacy_kernel 10.6.8

@Fabiuzi, you need AppleAzaliaAudio and the problem will be gone

@maya77, to run Kext Utility and other programs without crashing, you must leave just 4GB RAM
I am looking also for something to fix this (to run all without crashing with 16GB RAM) but till now I did not have any success
Reply With Quote
  #7  
Old 01-09-2012, 03:28 PM
leadermar leadermar is offline
Cheetah
 
Join Date: Jan 2012
Posts: 1
Quote:
Originally Posted by oslen View Post
I have the same mobo (M4A89GTD PRO/USB3) and processor (AMD Phenom II X6 1090T) i am running SL 10.6.8 with legacy_kernel 10.6.8

@Fabiuzi, you need AppleAzaliaAudio and the problem will be gone

@maya77, to run Kext Utility and other programs without crashing, you must leave just 4GB RAM
I am looking also for something to fix this (to run all without crashing with 16GB RAM) but till now I did not have any success
Hello, I also have your same motherboard, only that when I go to upgrade from 10.6.7 to 10.6.8, I crash all 32-bit applications, even if I put in the boot
Code:
maxmem = 4096
, how did you ?
Excuse my English, I'm Italian



💡 Deploy cloud instances seamlessly on DigitalOcean. Free credits ($100) for InfMac readers.

Reply With Quote