InfiniteMac OSx86  


Reply
 
Thread tools Display modes
  #1  
Old 05-17-2008, 04:55 PM
Puttabong's Avatar
Puttabong Puttabong is offline
 
Join Date: Jan 2008
Posts: 7,777
[How to] fix Rosetta (Crashing PPC Applications)

First of all you should check whether Rosetta is installed properly.

To do this, launch a Terminal & type:

/usr/libexec/oah/translate

If Rosetta runs fine, it should give this output:


If it doesn't work and says "Illegal instruction", "Bus Error" or something similiar, please try this:

1. Download this file: http://rapidshare.com/files/96033590/oah.zip.html

2. As root, move /usr/libexec/oah directory somewhere safe for backup

3. unzip the downloaded file into /usr/libexec/

4. Enjoy PPC Applications!

--------------------------------------------
If you prefer using the command line:

Open Terminal,

sudo -s
cd /usr/libexec
cp -R oah oah.bak
rm -rf /usr/libexec/oah
cp -R ~/Downloads/oah .
Reply With Quote
  #2  
Old 05-17-2008, 07:21 PM
naquaada's Avatar
naquaada naquaada is offline
 
Join Date: Jan 2008
Location: Germany
Posts: 1,216
If you don't like the teminal and want to do this with the Finder, do it like this

- Press Alt+Shift+G. Enter as path /usr/libexec/ (Command+Shift+G on a Mac Keyboard)
- search for 'oah' and open it
- double-click 'translate'. A window with the message should appear.

In case you have to replace 'oah' copy the old version to a safe place like Puttabong told. Now copy the new version into the directory. You have to enter your password. After this use the Disk Utility and repair the permissions.

Info: I don't tested it 'cause my Rosetta works. If somebody tries it post the results here.

2 Opteron systems: OSx86 10.5.8, Andy's 9.8.0 kernel, Asus A8N-SLI Premium, Opteron 185 o'clocked @ 2 x 2,95 GHz (2nd system 2.6 GHz), ATI Radeon HD2600XT 256MB Dual-Monitor 2x HP L2035, 4 GB RAM, Griffin FireWave as main audio device, Marvell + nForce LAN, Asus U3S6 USB3/SATA6 card, 5,5 TB harddisk, Firewire 800 card, Apple Remote + eHome IR receiver, 2x Wacom serial graphics tablet, Canon Pixma iP4700, Logitech Internet Navigator wireless keyboard/mouse combination.

My Audio stuff: M-Audio Transit USB (default audio), M-Audio ProFire 610, M-Audio ProFire Lightbridge (34 channels) using Creamware A16 ADAT converter MIDI: M-Audio Midiman 4x MIDI interfaceBehringer Audio Mixers: Xenyx 1002, Xenyx 1002FX, Xenyx 1202FX, Eurorack UB1002FX, Eurorack MX1804FX, Eurorack MX262A • FX devices: Lexicon MPX100 DSP, Behringer DSP-1000 Virtualizer, Behringer MiniFEX 800 DSP, Behringer Multicom Pro MDX4400 compressor RETRO: MSSIAH midi/sequencer/synthesizer cardridge for the C64 (Dual-SID), Steinberg M.S.I. MIDI Interface for C64
Reply With Quote
  #3  
Old 10-08-2008, 04:58 PM
nicholasblock nicholasblock is offline
Puma
 
Join Date: Oct 2008
Location: Green Bay,WI
Posts: 19
tried that

when i first ran the cmd to see if roseta was installed my whole pc shut down so i did what he wrote in the thread after i did a test to see if it worked and this is what i got

no such file or directory
Reply With Quote
  #4  
Old 10-08-2008, 10:48 PM
milanca's Avatar
milanca milanca is offline
 
Join Date: Jan 2008
Location: Serbia and Montenegro
Posts: 326
A couple of weeks ago i encountered my first problem with rosetta when i wanted to setup my amd box to be used via apple remote desktop from my intel box. No-IP for mac is running on rosetta, i needed it and it was crashing. I fixed the issue with 'Rosetta fix', i believe, from Kalyway. Working flawlessly so far. Not sure upon what it's based on, but i think its a bit obsolete version(just checked -- its only translate fixed file in the pkg), fine working though. Will try this Puttabong for sure, thanks man.

Last edited by milanca; 10-09-2008 at 12:12 AM.
Reply With Quote
  #5  
Old 06-25-2009, 10:44 PM
bullys1974 bullys1974 is offline
Cheetah
 
Join Date: Nov 2008
Posts: 10
hi Guys...

i don´t know what it could be... i cannot install PPC Apps anymore.

i am on 10.5.7 with andy voodo 9.60 kernel
my system runs very fine:

gigabyte EP35DS3
Quad6600 2,4GHz
SATA Drives
ATI HD Radeon 3650 all enabled

Now i want to install the software from datacolor to calibrate my monitor with a spyder3pro but it crashes on every try
i learned now about PPC apps and Rosetta in the last 4 hours. so i downloaded the application "transmission" to see if its a rosetta issue... and i didnt succed to install transmission - installer crashed on startup

my console logged: BUS error (see attachment)


the install-error log logged:

Code:
Process:		 Spyder3Elite_Installer [285]
Path:			/Volumes/Daten/Downloads/Spyder3Elite_3.0.5_Installer/
						Contents/MacOS/Spyder3Elite_Installer
Identifier:	  com.MindVision.InstallerVISE
Version:		 8.5 (Installer VISE 8.5
© MindVision Software 1991-2005)
Code Type:	   PPC (Translated)
Parent Process:  launchd [113]

Interval Since Last Report:		  1063 sec
Crashes Since Last Report:		   4
Per-App Interval Since Last Report:  0 sec
Per-App Crashes Since Last Report:   1

Date/Time:	   2009-06-24 22:16:12.721 +0200
OS Version:	  Mac OS X 10.5.7 (9J61)
Report Version:  6
Anonymous UUID:  AA2A56B4-A8BA-4784-AEBC-D13E9E9D55BD

Exception Type:  EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000
Crashed Thread:  0

Thread 0 Crashed:
0   ???						   	0000000000 0 + 0
1   translate					 	0xb809560e 0xb8000000 + 611854
2   translate					 	0xb80957ab 0xb8000000 + 612267
3   translate					 	0xb813cd60 spin_lock_wrapper + 2868
4   translate					 	0xb813cff0 spin_lock_wrapper + 3524
5   translate					 	0xb81541d2 spin_lock_wrapper + 98214
6   translate					 	0xb801169b 0xb8000000 + 71323
7   translate					 	0xb81555eb spin_lock_wrapper + 103359[left]
8   translate					 	0xb813c778 spin_lock_wrapper + 1356
9   translate					 	0xb800400e 0xb8000000 + 16398

Thread 0 crashed with X86 Thread State (32-bit):
  eax: 0xb81cda8d  ebx: 0xb81558cd  ecx: 0x00000073  edx: 0x00000007
  edi: 0xbffffaf0  esi: 0xb81cda31  ebp: 0xb7fffa48  esp: 0xb7ffe5ec
   ss: 0x0000001f  efl: 0x00010246  eip: 0x00000000   cs: 0x00000017
   ds: 0x0000001f   es: 0x0000001f   fs: 0x00000000   gs: 0x00000037
  cr2: 0x00000000

Binary Images:
0xb8000000 - 0xb81d7fe7  translate ??? (???) /usr/libexec/oah/translate

Translated Code Information:
NO CRASH REPORT


Here is what i tried so long:

- i did the rosetta fix (downloaded and copied fixed translation to /usr/libexec/oah/)
- terminal check of translate is ok - no errors
Code:
Usage: /usr/libexec/oah/translate [-argv0 <file>] [-b] [-z <file>] <subject program> <subject arguments>

 Options:
	   -argv0
			  Override argv[0] for subject program execv, execve calls.
	   -b
			  Display the current baseline version.
	   -z <config file>
 Config file.
logout

[Prozess beendet]


- bootet with -legacy - no luck
- repaired permissions - no luck

what can i do to get PPC apps installed again ?

pls help

regards bullys
Reply With Quote
  #6  
Old 06-28-2009, 06:37 PM
bullys1974 bullys1974 is offline
Cheetah
 
Join Date: Nov 2008
Posts: 10
hi there,
since there was no reply i can post a new question.
i installed my system new with IPC 10.5.6 and was able to install my ppc-app that was not possible to be installed before.

when i updated to 10.5.7 and installed andys 9.6 kernel i tested the installer again... and now i cannot install it anymore.. so it has to be an update issue...

any clue on this ?
my ppc apps and some updates can now be not installed

regards bullys
Reply With Quote
  #7  
Old 06-29-2009, 07:51 PM
bullys1974 bullys1974 is offline
Cheetah
 
Join Date: Nov 2008
Posts: 10
Kernel 9.70 and System.kext didnt help
pls help on this if u know how to fix this

cheers
Reply With Quote
  #8  
Old 06-30-2009, 10:59 PM
bullys1974 bullys1974 is offline
Cheetah
 
Join Date: Nov 2008
Posts: 10
solved it by installing the 10.5.7 comboupdate by downloading and not installing it via softwareupdate
YES YES YES YES YES YES YES YES YES YES YES YES YES YES YES YES YES YES YES YES YES YES YES

Even 10.5.7 running on original kernel

cheers
Reply With Quote
  #9  
Old 07-01-2009, 08:36 AM
Voyn1x's Avatar
Voyn1x Voyn1x is offline
 
Join Date: Jan 2008
Location: United Kingdom
Posts: 554
Glad you got it sorted.

Mac OS X 10.6.4 Retail || Intel Core2 Duo E8200 2.66GHz || Gigabyte G31M-ES2L || GeForce 6600 GT 128MB || Realtek ALC883 Audio || Realtek RTL8169 LAN || Samsung SpinPoint F1 1TB HD || Sony Dual Layer IDE DVD RW DW-D22A || Apple Aluminium Keyboard || Mighty Mouse

MacBook Pro || 2.4Ghz Core 2 Duo || 200Gb HD || 2Gb Ram || NVIDIA GeForce 8600M GT

iPhone 4 || 16Gb
Reply With Quote
  #10  
Old 07-06-2009, 10:06 AM
bullys1974 bullys1974 is offline
Cheetah
 
Join Date: Nov 2008
Posts: 10
yes me too sometimes its so easy



Mac OSX 10.5.7 Vanilla on
Gigabyte GA-EP35-DS3 (rev 2.1) F3
Intel Core 2 Quad Q6600 - 2.4 GHz
6 GB DDR2 / 667 MHz
nVdia GeForce 9500GT DDR3 512 MB RAM EFI
3 TB SATA HDD connected via AHCI
SATA - HP CD/DVD RW
Audio via ALC889a
Networking
Apple Keyboard
Wacom Tablett
working Sleep
Reply With Quote
Reply
Thread Tools
Display Modes