InfiniteMac OSx86  


Reply
 
Thread tools Display modes
  #1  
Old 09-15-2010, 04:24 PM
relorium relorium is offline
Cheetah
 
Join Date: Sep 2010
Posts: 3
p5kpl-am 10.6.4 lan problem

Hi guys ive been stuck on these for 2 weeks already. installed everything using universal installer 10.6.2 installed kext for my video card and the on board audio and the usb ports, problem is the on board lan [Realtek RTL8102E/RTL8103E Family PCI-E Fast Ethernet NIC (NDIS 6.20)] i used the rt1000.kext it didn't work, it detected the lan but i can't connect to the internet, When using dhcp it says' it has a self assigned ip?

can anyone help? pls it would be much appriciated thanks :P
Reply With Quote
  #2  
Old 09-17-2010, 01:42 PM
Harju Harju is offline
Cheetah
 
Join Date: Sep 2010
Posts: 1
I had a similar problem where I had to open terminal and do
Code:
sudo ifconfig en# down
sudo ifconfig en# up
I don't have this issue after patching with latest version of rt1000 however.

EDIT: # is ofc the number of you network device that you can find by just doign "ifconfig" in terminal.
Reply With Quote
  #3  
Old 09-18-2010, 05:26 PM
relorium relorium is offline
Cheetah
 
Join Date: Sep 2010
Posts: 3
what version did you use?? rt1000.kexts really have confusing names hahah they don't indicate which is the latest version and how did ifconfig help before?? do you suggest i do the same?? by the way im using 64bit os thanks for the reply

tried the sudo ifconfig thing here's what happens

i type

sudo ifconfig en0 down

then it asks for password

i type the password

then i type

sudo ifconfig en0 up

what's supposed to happen?? im a newbie by the way

Last edited by relorium; 09-18-2010 at 06:35 PM.
Reply With Quote
  #4  
Old 09-23-2010, 06:40 PM
relorium relorium is offline
Cheetah
 
Join Date: Sep 2010
Posts: 3
This has been resolved: Download the new realtek ethernet adapter driver from realtek website ithing the version is 2.0.5 good luck hope this helps
Reply With Quote
  #5  
Old 10-11-2010, 03:46 PM
dvtwru's Avatar
dvtwru dvtwru is offline
Cheetah
 
Join Date: Nov 2009
Posts: 11
you use RTGNICv2.0.3.pkg for your Lan or paste my DSDT to Partition SL
my DSDT :http://www.mediafire.com/?kn5yce55nea5ab2
driver Lan :http://www.mediafire.com/?c57yimw71329u86
hope helps



💡 Deploy cloud instances seamlessly on DigitalOcean. Free credits ($100) for InfMac readers.


Snow 10.7.2
Intel core 2 Duo E2200, MB P5KPL-AM
VGA Nvidia 7200GS working perfect
Lan Realtek detected
Audio VIA working ( voodooHDA.kext, mic and line-out)
full support for OSX Lion 10.7.2

Last edited by dvtwru; 10-11-2010 at 03:51 PM.
Reply With Quote