InfiniteMac OSx86  

🌅 Dive into Web3 and Crypto, join FTX! 🚀

Reply
 
Thread tools Display modes
  #1  
Old 11-10-2010, 11:32 PM
Imkantus Imkantus is offline
 
Join Date: Jul 2009
Location: Germany
Posts: 779
10.6.5 is avaible via Softwareupdate...


AMD Phenom II X4 955 - ASRock AM3A770DE - 8GB DDR3-1333 - Radeon HD 5570 1GB passiv - BCM4318 802.11b/g - Snow Leopard Retail
+++
AMD Phenom X3 8450 - ASRock AM2NF6G-VSTA (BIOS L2.39) - 4GB DDR2-800 - Radeon HD 4650 512MB - Snow Leopard Retail (retired) / OpenBSD
Reply With Quote
  #2  
Old 11-11-2010, 01:10 AM
Taisto's Avatar
Taisto Taisto is offline
 
Join Date: Jan 2008
Location: TriCity, Poland
Posts: 517
My update was ~500mb. It was trouble free, and here is the full change list :

- improve reliability with Microsoft Exchange servers
- address performance of some image-processing operations in iPhoto and Aperture
- address stability and performance of graphics applications and games
- resolve a delay between print jobs
- address a printing issue for some HP printers connected to an AirPort Extreme
- resolve an issue when dragging contacts from Address Book to iCal
- address an issue where dragging an item from a stack causes the Dock to not automatically hide
- resolve an issue with Wikipedia information not displaying correctly in Dictionary
- improve performance of MainStage on certain Mac systems
- resolve spacing issues with OpenType fonts
- improve reliability with some Bluetooth braille displays
- resolve a VoiceOver issue when browsing some web sites with Safari 5

Oh, and we have a new kernel, Darwin 10.5.0 so don't forget to back up yours.


www.ultimae.com
Panoramic music, for panoramic people.

AMD Phenom II X6 3.5Ghz
AMD 990FX Chipset
Kingston HyperX 16GB 1600Mhz
AMD Radeon HD6850 X2 CrossFire
Seagate Barracuda Green 2TB
Reply With Quote
  #3  
Old 11-11-2010, 12:53 PM
wastez's Avatar
wastez wastez is offline
Panther
 
Join Date: Oct 2010
Posts: 182
Hello,

Does the xnu mach_kernel 10.5.0 work with amd too?
Would be really great to know.

Greets
Reply With Quote
  #4  
Old 11-11-2010, 01:42 PM
RayFlower RayFlower is offline
Jaguar
 
Join Date: Jan 2010
Posts: 93
I have yet to try it with my amd setup, experienced some trouble with my macbook pro 3.1 though.
It installs a new boot.efi so once i lipo'ed the new kernel i got some boot trouble, but replacing it with the old hacked one did the trick and i have a full 64 bit system again now and working wifi
Reply With Quote
  #5  
Old 11-11-2010, 01:44 PM
RayFlower RayFlower is offline
Jaguar
 
Join Date: Jan 2010
Posts: 93
Quote:
Originally Posted by wastez View Post
Hello,

Does the xnu mach_kernel 10.5.0 work with amd too?
Would be really great to know.

Greets
Most likely, no.
But if you're willing to experiment a bit you can use a older amd kernel with it, might break something though(last time around apf did).
Reply With Quote
  #6  
Old 11-11-2010, 02:54 PM
Imkantus Imkantus is offline
 
Join Date: Jul 2009
Location: Germany
Posts: 779
OK. Succesfully did it through Software-Update.

Andy's v5 rework of 10.4.0 legacy XNU is still working fine, after patching out a few CPUIDs + sysenter traps from libSystem.B*.dylib files:



ATI Framebuffer drivers have been reworked, but working without issues.

There are two new ATI Framebuffer called "Nomascus" und "Orangutan". ATI 5XXX owners who haven't yet been able to make their cards to work, should give those a try.

Anyway I'm pissed off... Stupid USB drivers stoped working after Update - I had to restore old versions of IOUSBFamily.kext & IOUSBMassStorageClass.kext from 10.6.4 - Due to lack of a keyboard I can't post my dmesg - but these lines are present in system.log
Code:
Nov 11 00:41:12 XYZs-Mac com.apple.kextd[12]: Failed to load /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBOHCI.kext - (libkern/kext) dependency load failed.
Nov 11 00:41:12 XYZs-Mac com.apple.kextd[12]: Load com.apple.driver.AppleUSBOHCI failed; removing personalities.
Nov 11 00:41:12 XYZs-Mac com.apple.kextd[12]: Failed to load /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBEHCI.kext - (libkern/kext) dependency load failed.
Nov 11 00:41:12 XYZs-Mac com.apple.kextd[12]: Load com.apple.driver.AppleUSBEHCI failed; removing personalities.
Nov 11 00:41:16 XYZs-Mac mtversionlog[72]: SWU: system version changed from 10.6.4 (10F569) to 10.6.5 (10H574)
Nov 11 00:41:16 XYZs-Mac bootlog[67]: BOOT_TIME: 1289432462 0
It seems there are others having the same trouble... - maybe this problem related to using an previous version of XNU Kernel, but I currently don't have the equipment for giving this a try...

Quote:
Originally Posted by wastez View Post
Does the xnu mach_kernel 10.5.0 work with amd too?
Would be really great to know.
Ofcourse unpatched / vanilla Kernel does not work on AMD. For the moment you will have to use 10.4.0 patched Kernel with 10.6.5 - I'd recommend you to back-up your Kernel Extensions etc as well.

Apple hasn't released the source code for 10.6.5, yet. Once it is avaible there is the possibility to start working on porting the current kernel patches to the latest kernel version. (And maybe to fix USB drivers as well. )

AMD Phenom II X4 955 - ASRock AM3A770DE - 8GB DDR3-1333 - Radeon HD 5570 1GB passiv - BCM4318 802.11b/g - Snow Leopard Retail
+++
AMD Phenom X3 8450 - ASRock AM2NF6G-VSTA (BIOS L2.39) - 4GB DDR2-800 - Radeon HD 4650 512MB - Snow Leopard Retail (retired) / OpenBSD
Reply With Quote
  #7  
Old 11-11-2010, 03:10 PM
gedna gedna is offline
Jaguar
 
Join Date: May 2009
Posts: 52
i can confirm, usb stop working after update, :/ thats strange
Reply With Quote
  #8  
Old 11-11-2010, 03:47 PM
RayFlower RayFlower is offline
Jaguar
 
Join Date: Jan 2010
Posts: 93
Out of curiosity, what GPU do you use imkantus?

I've been forced to use the macmini drivers with the patched ATY_init.kext with my 5750, any upgrades in the past has messed up the framebuffer for me?

I guess I'll wait with upgrading to 10.6.5 until the USB issue has been addressed although using the old kexts shouldn't be too much of an issue for now?
About your dmesg, have you tried to ssh into it from another computer?</captain obvious>
I don't know if this is a kernel related issue as I used the 10.5.3 kernel on my mbp earlier after installing the 10.6.5update and usb was working fine, anyhow thats just pure guess work on my part.

Also, safari seems to be a bit snappier after this update, could just be my imagination though.
Reply With Quote
  #9  
Old 11-11-2010, 08:19 PM
Imkantus Imkantus is offline
 
Join Date: Jul 2009
Location: Germany
Posts: 779
Quote:
Originally Posted by gedna View Post
i can confirm, usb stop working after update, :/ thats strange
It ain't strange - it sucks.

I have just put 10.6.5 to my Asus eee PC 900A (Intel Atom N270).
I am using latest 10.5.0 binpatched Kernel made teateam:
http://www.insanelymac.com/forum/ind...owtopic=197020

I am fine using 10.5.0 XNU, but once I am using 10.4.0 I have the same USB problems like on the AMD machine. So I think this issue is actually Kernel related...

I have attached dmesg from the netbook, made using 10.4.0 legacy kernel by nawcom for larger dmesg log space (same situation using 10.4.0 binpatched Kernel).

So those of you who cannot boot Darwin 10.5.0 yet, should make a back-up of 10.6.4 IOUSBFamily.kext & IOUSBMassStorageClass.kext before update!!!

Would be nice if some other people who have 10.6.5 upgraded Hacks could try booting 10.4.0 XNU to prove or disprove this.

Quote:
Originally Posted by RayFlower View Post
Out of curiosity, what GPU do you use imkantus?

I've been forced to use the macmini drivers with the patched ATY_init.kext with my 5750, any upgrades in the past has messed up the framebuffer for me?
Well I am still on the RV730 GPU / HD4650 card mentioned in my signature. It currently fits my needs, so no reason to buy a 5000 series card yet.
As far as I figured out and read in IRC, latest drivers work pretty much the same as those from "10.6.4 Graphics Update v1" did.

Anyway if you are fine using those drivers from MacMini Image, make a back-up of the following 3 kext files before update ATI5000Controller.kext, ATIFramebuffer.kext & ATISuppor.kext and use them in combination with latest ATIRadeonX3000.kext from 10.6.5 Update - should work.

Quote:
Originally Posted by RayFlower View Post
I guess I'll wait with upgrading to 10.6.5 until the USB issue has been addressed although using the old kexts shouldn't be too much of an issue for now?
I have no problems using 10.6.4 kexts so far, but i prefer solutions instead of work-arounds.
Attached Files
File Type: txt dmesg.txt (9.4 KB, 18 views)

AMD Phenom II X4 955 - ASRock AM3A770DE - 8GB DDR3-1333 - Radeon HD 5570 1GB passiv - BCM4318 802.11b/g - Snow Leopard Retail
+++
AMD Phenom X3 8450 - ASRock AM2NF6G-VSTA (BIOS L2.39) - 4GB DDR2-800 - Radeon HD 4650 512MB - Snow Leopard Retail (retired) / OpenBSD
Reply With Quote
  #10  
Old 11-11-2010, 10:28 PM
RayFlower RayFlower is offline
Jaguar
 
Join Date: Jan 2010
Posts: 93
Thanks, that did the trick, got a fully functional system now, and afp works too.
Let's just hope apple releases the kernel sources quickly so we can take advantage of the new kernel and hopefully bring even better support for us AMD users

EDIT:
It seems I spoke too soon, with -force64 i can't run 32bitcode, uhm could you in depth describe the patching procedure please?

EDIT
It seems like this upgrade installed a new /usr/lib/dyld, replacing it with a prepatched one did the trick.



💡 Deploy cloud instances seamlessly on DigitalOcean. Free credits ($100) for InfMac readers.


Last edited by RayFlower; 11-11-2010 at 11:57 PM.
Reply With Quote
Reply
Thread Tools
Display Modes