InfiniteMac OSx86  


Reply
 
Thread tools Display modes
  #1  
Old 01-01-2009, 07:08 AM
cmdshft's Avatar
cmdshft cmdshft is offline
Panther
 
Join Date: Dec 2008
Location: Hackensack, NJ
Posts: 240
[How To] PNY GeForce 7600GS 512MB AGP

This is for 10.5.6.

I recently bought a 7600GS 512MB AGP card, and I was informed that all 7x00 series cards that had more than 256MB VRAM had issues in OS X that required flashing the ROM BIOS on the card.

Thanks to another member on InsanelyMac, the card is now working at FULL 512MB, with QE/CI+Rotation WITHOUT FLASHING THE BIOS! No more risking a bricked GFX card.

Here's how you can do it:

First, download these kexts and extract them to a safe location.

Make sure that you have UInstaller by ~pcwiz installed.

Next, make sure to go into your extensions folder ( /System/Library/Extensions ) and delete all Intel and ATI video drivers.

Using UInstaller, check the option to install kexts from HD, and then press browse and select all the kexts you downloaded from the link above, and then press install.

Next, delete Extensions.mkext in /System/Library and reboot, and at darwin, type -f.

Mac OS X Leopard 10.5.8 (9L30) | Chameleon 2.0 RC3 | Intel Pentium 4 3Ghz 800Mhz FSB HyperThread 1MB L2 cache SSE3 1MB L2 cache works, cosmetic display of 512KB L2 cache | Asus P4V8X-MX VIA Chipset, VIA-VT8237 Southbridge | AC97 VIA8237 | Dual 1GB 333Mhz DDR SDRAM | nVidia PNY GeForce 7600GS 512MB 8x AGP DVI/TV-Out/VGA [NVinject 0.2.1; QE/CI/QuartzGL/Rotation] | Darwin Kernel Version 9.7.0: Sun Jun 14 20:48:28 IST 2009; Voodoo 2.0 Intel alpha3 :xnu-1228.12.14/BUILD/obj/RELEASE_I386 i386

Last edited by cmdshft; 01-09-2009 at 06:04 PM.
Reply With Quote
  #2  
Old 02-03-2009, 06:13 PM
gipo's Avatar
gipo gipo is offline
 
Join Date: Feb 2008
Location: Italy
Posts: 105
i've got a 7600gs too... but 256mb, and i'm beating with it to make it work on your ipcx86 release. i didn't ticked any graphic driver on installation, so osx start in vga mode, but then, i tried several injectors, tried old kexts working with 10.5.5 and the result it is always black screen with idle cursor and stop.
Restart with -x in safemode give a 1680x1050 right resolution (without qe and ci) with most of them.
(Vendor: NVIDIA (010de) Device ID:00392 Revision ID: 000a1)

Snow Leopard Client-Server 10.6.5 by Hazard
10.6.5 legacy kernel for INTEL/AMD V2 Kernel
Cpu: AMD Phenom X4 965
Motherboard: Asus M4A78 pro AMD 780G / AMD SB700 chipset
Ram: 6 gb @ 800 Mhz
Gpu: nVidia 8800gts 512 pci-xpress - Audio integrated: VIA VT1708S
AHCI mode HDs

Last edited by gipo; 02-03-2009 at 06:24 PM.
Reply With Quote
  #3  
Old 02-03-2009, 07:28 PM
cmdshft's Avatar
cmdshft cmdshft is offline
Panther
 
Join Date: Dec 2008
Location: Hackensack, NJ
Posts: 240
Add your device ID into the kexts, the 512MB and 256MB cards have different ID's.

Mac OS X Leopard 10.5.8 (9L30) | Chameleon 2.0 RC3 | Intel Pentium 4 3Ghz 800Mhz FSB HyperThread 1MB L2 cache SSE3 1MB L2 cache works, cosmetic display of 512KB L2 cache | Asus P4V8X-MX VIA Chipset, VIA-VT8237 Southbridge | AC97 VIA8237 | Dual 1GB 333Mhz DDR SDRAM | nVidia PNY GeForce 7600GS 512MB 8x AGP DVI/TV-Out/VGA [NVinject 0.2.1; QE/CI/QuartzGL/Rotation] | Darwin Kernel Version 9.7.0: Sun Jun 14 20:48:28 IST 2009; Voodoo 2.0 Intel alpha3 :xnu-1228.12.14/BUILD/obj/RELEASE_I386 i386
Reply With Quote
  #4  
Old 02-03-2009, 07:33 PM
gipo's Avatar
gipo gipo is offline
 
Join Date: Feb 2008
Location: Italy
Posts: 105
which injector do you think it's best? nvdarwin, nvinject or what else?

Snow Leopard Client-Server 10.6.5 by Hazard
10.6.5 legacy kernel for INTEL/AMD V2 Kernel
Cpu: AMD Phenom X4 965
Motherboard: Asus M4A78 pro AMD 780G / AMD SB700 chipset
Ram: 6 gb @ 800 Mhz
Gpu: nVidia 8800gts 512 pci-xpress - Audio integrated: VIA VT1708S
AHCI mode HDs
Reply With Quote
  #5  
Old 02-03-2009, 08:15 PM
cmdshft's Avatar
cmdshft cmdshft is offline
Panther
 
Join Date: Dec 2008
Location: Hackensack, NJ
Posts: 240
Any that work. I recommend using the 7600GS package on iPC, boot with -x, change the ID to your cards' ID in the proper kexts and reboot with -f. The NVinject in that package is what I use and it's working just fine.


Mac OS X Leopard 10.5.8 (9L30) | Chameleon 2.0 RC3 | Intel Pentium 4 3Ghz 800Mhz FSB HyperThread 1MB L2 cache SSE3 1MB L2 cache works, cosmetic display of 512KB L2 cache | Asus P4V8X-MX VIA Chipset, VIA-VT8237 Southbridge | AC97 VIA8237 | Dual 1GB 333Mhz DDR SDRAM | nVidia PNY GeForce 7600GS 512MB 8x AGP DVI/TV-Out/VGA [NVinject 0.2.1; QE/CI/QuartzGL/Rotation] | Darwin Kernel Version 9.7.0: Sun Jun 14 20:48:28 IST 2009; Voodoo 2.0 Intel alpha3 :xnu-1228.12.14/BUILD/obj/RELEASE_I386 i386
Reply With Quote
  #6  
Old 02-03-2009, 09:02 PM
gipo's Avatar
gipo gipo is offline
 
Join Date: Feb 2008
Location: Italy
Posts: 105
Thanks... i'll try soon when i'll be home.

p.s. which are the proper kexts that i must modify?

Snow Leopard Client-Server 10.6.5 by Hazard
10.6.5 legacy kernel for INTEL/AMD V2 Kernel
Cpu: AMD Phenom X4 965
Motherboard: Asus M4A78 pro AMD 780G / AMD SB700 chipset
Ram: 6 gb @ 800 Mhz
Gpu: nVidia 8800gts 512 pci-xpress - Audio integrated: VIA VT1708S
AHCI mode HDs
Reply With Quote
  #7  
Old 02-03-2009, 09:45 PM
cmdshft's Avatar
cmdshft cmdshft is offline
Panther
 
Join Date: Dec 2008
Location: Hackensack, NJ
Posts: 240
Just these:

GeForce.kext
NVDANV40Hal.kext
NVDAResman.kext

Mac OS X Leopard 10.5.8 (9L30) | Chameleon 2.0 RC3 | Intel Pentium 4 3Ghz 800Mhz FSB HyperThread 1MB L2 cache SSE3 1MB L2 cache works, cosmetic display of 512KB L2 cache | Asus P4V8X-MX VIA Chipset, VIA-VT8237 Southbridge | AC97 VIA8237 | Dual 1GB 333Mhz DDR SDRAM | nVidia PNY GeForce 7600GS 512MB 8x AGP DVI/TV-Out/VGA [NVinject 0.2.1; QE/CI/QuartzGL/Rotation] | Darwin Kernel Version 9.7.0: Sun Jun 14 20:48:28 IST 2009; Voodoo 2.0 Intel alpha3 :xnu-1228.12.14/BUILD/obj/RELEASE_I386 i386
Reply With Quote
  #8  
Old 02-03-2009, 09:52 PM
gipo's Avatar
gipo gipo is offline
 
Join Date: Feb 2008
Location: Italy
Posts: 105
thanks again...

Snow Leopard Client-Server 10.6.5 by Hazard
10.6.5 legacy kernel for INTEL/AMD V2 Kernel
Cpu: AMD Phenom X4 965
Motherboard: Asus M4A78 pro AMD 780G / AMD SB700 chipset
Ram: 6 gb @ 800 Mhz
Gpu: nVidia 8800gts 512 pci-xpress - Audio integrated: VIA VT1708S
AHCI mode HDs
Reply With Quote
  #9  
Old 02-05-2009, 02:36 PM
gipo's Avatar
gipo gipo is offline
 
Join Date: Feb 2008
Location: Italy
Posts: 105
So, perfect, i modify kexts inserting my id... needed to modify the injector kext too and on reboot with -f i had full resolution and CI + QE.
I had issues with finder prefs and keyboard panel, resolved with files from 10.5.5.
Last problem, well it's not a real problem, is the processor name in sys info, my athlon5200 is seeing as an intel core2duo... may be a problem? is there a solution that i don't know?
Kernel is 32bit in default? at 64 running as well?

Snow Leopard Client-Server 10.6.5 by Hazard
10.6.5 legacy kernel for INTEL/AMD V2 Kernel
Cpu: AMD Phenom X4 965
Motherboard: Asus M4A78 pro AMD 780G / AMD SB700 chipset
Ram: 6 gb @ 800 Mhz
Gpu: nVidia 8800gts 512 pci-xpress - Audio integrated: VIA VT1708S
AHCI mode HDs
Reply With Quote
  #10  
Old 02-05-2009, 05:30 PM
cmdshft's Avatar
cmdshft cmdshft is offline
Panther
 
Join Date: Dec 2008
Location: Hackensack, NJ
Posts: 240
Glad to hear that it worked for the most part. (I didn't have to use any graphics stuff from 10.5.5 though, so that's weird that you did.)

As for the CPU name, I think it's done on purpose to allow compatibility with apps that do CPUID checking. You can manually fix it in About This Mac, but as far as it's appearance in System Profiler, I think you're SOL as long as you're using Voodoo XNU 9.5.0. I wont get too deep into it (this thread isn't for it, but check out the Voodoo documentation which you can find on the site, it's very helpful).



💡 Deploy cloud instances seamlessly on DigitalOcean. Free credits ($100) for InfMac readers.


Mac OS X Leopard 10.5.8 (9L30) | Chameleon 2.0 RC3 | Intel Pentium 4 3Ghz 800Mhz FSB HyperThread 1MB L2 cache SSE3 1MB L2 cache works, cosmetic display of 512KB L2 cache | Asus P4V8X-MX VIA Chipset, VIA-VT8237 Southbridge | AC97 VIA8237 | Dual 1GB 333Mhz DDR SDRAM | nVidia PNY GeForce 7600GS 512MB 8x AGP DVI/TV-Out/VGA [NVinject 0.2.1; QE/CI/QuartzGL/Rotation] | Darwin Kernel Version 9.7.0: Sun Jun 14 20:48:28 IST 2009; Voodoo 2.0 Intel alpha3 :xnu-1228.12.14/BUILD/obj/RELEASE_I386 i386
Reply With Quote
Reply
Thread Tools
Display Modes