InfiniteMac OSx86  

🌅 Dive into Web3 and Crypto, join FTX! 🚀

Reply
 
Thread tools Display modes
  #11  
Old 09-17-2009, 07:38 AM
miliuco miliuco is offline
 
Join Date: Jul 2009
Location: Spain
Posts: 62
"...yo usaria solo dsdt.aml en el disco hasta que tengas uno que sabes que funciona perfecto, solo entonces yo lo parchearia, y aun asi no le veo muchas ventajas..."

Completamente de acuerdo con esa opinión.

10.7.1 / Gigabyte P55-USB3 / i5 750 / 9800gt / http://miliuco.es
Reply With Quote
  #12  
Old 09-18-2009, 06:56 PM
uzmi uzmi is offline
Puma
 
Join Date: Jun 2009
Posts: 24
Hola:
Gracias. Seguiré vuestro consejo. Uds tienen mas tiempo en esto y vuestra experiencia cuenta mucho.

Perdón a quienes leyeron antes de esta edición pero debido a mis "avances" debo cambiar el pedido de ayuda.
Paso a detallar:

1) Instalé Snow en el otro Hd Sata, con un boot cd y luego cambiando al DVD Snow, chamaleon, kext, etc (el método es similar a cualquier instalación del Leopard nativo. No es necesario instalar desde Leopard)

2) Partiendo desde un DSDT de video de otra gráfica, modifiqué con los valores de mi gráfica y funcionó perfectamente. Probé en leopard ese DSDT y también funcionó.

3) El audio:
Con el método de Koalala's logré un DSDT para mi audio (alc 888-0) que en Leopard funcionó usando AppleHDA.kext y LegacyHDA.kext. Tengo audio en Leopard, sin embargo los conectores frontales de auriculares y micrófono, no funcionan (con el método Taruga si lo hacían). Ese mismo DSDT para Snow no funciona (usando el AppleHDA.kext solo o combinado con LegacyHDA.kext)
Me puse a investigar el DSDT de Koalala's y los valores de PinConfigurations que obtengo con Ioreg y no coincide ninguno. En Koalala's hay 40 valores y en Ioreg me figuran 48.
Modifiqué con estos 48 valores pero tampoco funcionan. En realidad no estoy seguro de haberlo hecho correctamente o si tendría que modificar algo mas aparte de "codec-id", "layout-id", y el los PinConfigurations (Ni idea que hacer con los Buffer (0x..)

Así que nuevamente:
Necesito que me orienten o si alguien tiene una guía, (en "SanTito" Google no encuentro nada) con la que pueda aprender a inyectar el audio.

Si alguien tiene tiempo y deseos de ayudarme adjunto un zip los datos de mi audio con Ioreg y el HDEF logrado con el método Koalala's.

Gracias de nuevo

http://www.megaupload.com/?d=TWDR4B9D

Intel Core 2 Duo E 8400 / GA-P35-DS3L / 4GB DDR 2 667 / HD SATA II / Grab DL SATA / Teclado y raton inalámbricos / Ati 4850 1 GB / Wifi TL-WN851N

Last edited by uzmi; 09-19-2009 at 11:59 AM. Reason: Cambio en la ayuda solicitada
Reply With Quote
  #13  
Old 09-20-2009, 12:44 PM
uzmi uzmi is offline
Puma
 
Join Date: Jun 2009
Posts: 24
Hola:
Una duda que quizás sea tonta, pero ¿como modifico com.apple.Boot.plist para que arranque en 64 y no en 32 y lo haga en verbose mode? Lo he intentado por mi cuenta y no lo soluciono.

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>arch=x86_32</string>
<key>device-properties</key>
<string>-v</string>
<key>Timeout</key>
<string>3</string>
</dict>
</plist>

Deseo probar en 64 porque con el DSDT.aml, en Acerca de este mac --> Audio(integrado) salen las características del chip de sonido pero en Preferencias del sistema -->Sonido no figura nada en entrada y/o salida.
Pienso que pueda estar relacionado con que AppleHDA.kext y LegacyHDS.kext funcionen solo en 64.
Gracias.

Intel Core 2 Duo E 8400 / GA-P35-DS3L / 4GB DDR 2 667 / HD SATA II / Grab DL SATA / Teclado y raton inalámbricos / Ati 4850 1 GB / Wifi TL-WN851N
Reply With Quote
  #14  
Old 09-21-2009, 11:12 AM
thorazine74 thorazine74 is offline
 
Join Date: May 2009
Location: Spain
Posts: 411
Si tienes instaldos netkas pcefi el argumento es -x64, mira este otro hilo.

Code:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>Kernel</key>
    <string>mach_kernel</string>
    <key>Kernel Flags</key>
    <string>-x64 -v</string>
                 <key>Timeout</key>
    <string>3</string>
</dict>
</plist>
Que yo sepa AppleHDA funciona tanto en 32 como en 64 bits, y el Legacy como no tiene ningun codigo deberia funcionar tambien.

AsRock P45TS | C2D E8200 | GeForce 8600GTS
Mac OS X Snow Leopard 10.6.1 + Windows 7 Ultimate 6.1.7600 + Fedora 11
Reply With Quote
  #15  
Old 09-23-2009, 05:31 PM
uzmi uzmi is offline
Puma
 
Join Date: Jun 2009
Posts: 24
Hola:
Gracias thorazine 74, logré correr snow en 64 y tampoco funcionó el audio, pero borré AppleHDA.kext y use VoodooHDA.kext (en S/L/E) y conseguí esto:




No se, si es 5.1 o 2.1 pero funciona el conector delantero para auriculares.
Gracias a todos.

P.D. No se como editar el titulo para poner (Casi)Solucionado

Intel Core 2 Duo E 8400 / GA-P35-DS3L / 4GB DDR 2 667 / HD SATA II / Grab DL SATA / Teclado y raton inalámbricos / Ati 4850 1 GB / Wifi TL-WN851N

Last edited by uzmi; 09-23-2009 at 05:41 PM. Reason: More input
Reply With Quote
  #16  
Old 09-23-2009, 10:27 PM
miliuco miliuco is offline
 
Join Date: Jul 2009
Location: Spain
Posts: 62
Cuando dices:
Quote:
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>arch=x86_32</string>
<key>device-properties</key>
<string>-v</string>
<key>Timeout</key>
<string>3</string>
Date cuenta que el modificador -v no va en device-properties sino como un Kernel Flags, podría ser algo así:
Quote:
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>arch=x86_32 -v</string>
<key>Timeout</key>
<string>3</string>
Y como dice Thorazine74 hay 2 posibles modificadores para x64 dependiendo del arranque que uses, puede ser arch=x86_64 o -x64. Te pego aquí del propio Thorazine74 en el otro hilo:
Quote:
If you are using netkas PCEFI 10.x the boot arguments are -x32 or -x64
If you are using pure Chameleon rc3 the arguments are arch=i386 or arch=x86_64
Y también:
Quote:
arch=i386: 32 bit kernel / 32 or 64 bit apps
arch=i386 -legacy: 32 bit kernel / 32 bit apps
arch=x86_64: 64 bit kernel / 32 or 64 bit apps
arch=x86_64 -legacy: 64 bit kernel / 32 bit apps.

10.7.1 / Gigabyte P55-USB3 / i5 750 / 9800gt / http://miliuco.es

Last edited by miliuco; 09-23-2009 at 10:31 PM.
Reply With Quote
  #17  
Old 09-23-2009, 10:49 PM
uzmi uzmi is offline
Puma
 
Join Date: Jun 2009
Posts: 24
Hola:

Quizás no se distingue bien en mi post anterior pero estoy en 64 y lo logre modificando com.apple.Boot.plist de esta forma:


<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>arch=x86_64 -v</string>
<key>Timeout</key>
<string>5</string>
</dict>
</plist>

La versión que postee antes estaba mal porque había borrado una linea y quedo colgada esa sentencia.
Como siempre, gracias miliuco.

P.D. De hecho lo saqué de la misma página que mencionas (Gracias thorazine74). Mi San "Tito" google hecha humo.

Intel Core 2 Duo E 8400 / GA-P35-DS3L / 4GB DDR 2 667 / HD SATA II / Grab DL SATA / Teclado y raton inalámbricos / Ati 4850 1 GB / Wifi TL-WN851N

Last edited by uzmi; 09-23-2009 at 10:53 PM. Reason: More input
Reply With Quote
  #18  
Old 09-24-2009, 09:57 PM
uzmi uzmi is offline
Puma
 
Join Date: Jun 2009
Posts: 24
Thumbs up Solucionado

¡¡¡¡EUREKA!!!! ¡¡¡LO LOGRE!!!

Volví a hacer una instalación limpia.

Reinicio con SLBoot.
Cambio el cd SLBoot por el dvd Snow 10a432.
Instalo (desmarcando impresoras en Personalizar)
Reinicio al finalizar la instalación, cambiando de nuevo el DVD Snow por CD SLBoot.
Configuro.
Actualizo a 10.6.1 y reinicio.
Instalo Chameleon 2RC 3
En la carpeta Extra creo otra carpeta llamada Extensions e instalo estos kext's:
AHCIPortInjector
fakesmc (version 2)
IOAHCIBlockStorageInjector
JMicronATA
LegacyHDA
NullCPUPowerManagement
OpenHaltRestart
PlatformUUID
SleepEnabler

También en extra pongo el DSDT.aml, com,apple.Boot.plist y smbios.plist.
Instalo Kext Utility 2.3.2 y lo ejecuto.
Reinicio ….y voilá: tengo sonido

¡De put.. madre! ¡Gracias a todos!

Nota: En todos los reinicios se desconfiguraba la bios y tenía que volver a configurarla correctamente, hasta poner el DSDT.aml.
(Ya borré Leopard)



💡 Deploy cloud instances seamlessly on DigitalOcean. Free credits ($100) for InfMac readers.


Intel Core 2 Duo E 8400 / GA-P35-DS3L / 4GB DDR 2 667 / HD SATA II / Grab DL SATA / Teclado y raton inalámbricos / Ati 4850 1 GB / Wifi TL-WN851N
Reply With Quote
Reply
Thread Tools
Display Modes